LiveGraph not reading .lgdat file in Linux

Ashish
2011-12-10
2013-05-28
  • Ashish
    Ashish
    2011-12-10

    Hi,

    I am using LiveGraph in my application to plot some data. It works fine when I run from eclipse, but when I build an executable .jar file, on loading LiveGraph, I get error message 'Error while loading xxx.lgdat file'. I am programming in Ubuntu and saving the data file in /tmp. On executing the .jar file, I observed that .lgdat file was saved in /tmp but LiveGraph couldn't read the file. The data is entered in .lgdat file but I don't know why it is unable to load the data file.

    I observed that the file has different permission when running from Eclipse and .jar, but even after changing the permissions, Live graph didn't read the file when I tried to execute from .jar file.

    Why do we have such error message? Any suggestion?
    Thanks,
    Ashish.

     
  • Greg Paperin
    Greg Paperin
    2012-03-15

    Please verify under what user you are running LiveGraph (you should see it as a Java process). You need to make sure that the user under which you run the Java VM that executes LiveGraph has the right permissions to access your data file.