Hi all,
 
I have some trouble to get LIRC to run with my usb-device. I tried many different configurations and read alot of atricles in the www. Now I am at a point where I dont know what else to test. Maybe you can give me some hint what I am doing wrong.
 
The problem: irw does not give any output
I run the following in terminal1:
sudo lircd --nodaemon -H devinput -d /dev/lirc0
> lircd-0.9.0-pre1[6154]: lircd(devinput) ready, using /var/run/lirc/lircd
 
In terminal2:
irw
 
This will cause terminal1 to produce the following:
> lircd-0.9.0-pre1[6154]: accepted new client on /var/run/lirc/lircd
> lircd-0.9.0-pre1[6154]: initializing '/dev/lirc0'
> lircd-0.9.0-pre1[6154]: can't get exclusive access to events coming from `/dev/lirc0' interface
 
This is strange, because I took care to kill all other running lirc-applications.
 
When I press a key on my remote, I get this in terminal1:
> lircd-0.9.0-pre1[6154]: error reading '/dev/lirc0'
> lircd-0.9.0-pre1[6154]: error reading '/dev/lirc0'
> ......
 
Using irrecord and mode2 works fine. I even can generate a key-layout with irrecord. Just irw refuses to work.
 
My system is (uname -a):
Linux schwinn-media 3.2.0-4-amd64 #1 SMP Debian 3.2.46-1 x86_64 GNU/Linux
I installed lirc with "apt-get install lirc"
 
My hardware.conf and lircd.conf are attached.
I as well attached the printout of "cat /proc/bus/input/devices" into devices.txt
I use the "Media Center Ed. eHome Infrared Remote Transceiver (0609:0334)"
 
I am grateful for any help!
 
Thanks & Cheers,
 
Derek Freder