First of all, sorry about the duplicate first mails.

And thanks, it works now! Version 0.26 from CVS did the trick, I can get the transmitter to blink in all it's glory, so I can confirm that the SMK device works. I have a separate issue with irrecord only recording the same info no matter what button I press for my set top remote, but other remotes work. I'll send this to lirc@bartelmus.de to avoid spewing the list with logs, and be in accordance with the error reporting in the manual about adding remotes.

Thanks again guys, lirc truly is great software.

Stig

On 16 Nov 2006 20:41:00 +0000, Christoph Bartelmus <lirc@bartelmus.de> wrote:
Hi!

Stig Fjeldheim "stig@spicelab.net" wrote:
[...]
> my recently built HTPC is working quite well, but I'm having some problems
> getting the PVR150-MCE usb dongle to transmit signals to my set-top cable
[...]
> lirc_mceusb2[3]: SMK eHome Infrared Transceiver on usb1:3
[...]
> My guess is that Daniel's patch doesn't quite cover my hardware, but I'm
> hoping I've just missed something.

I just checked in a patch to CVS that fixed the transmitter mask setting
for the SMK transceiver. You should try if this also solves your
problem.

Christoph

-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys - and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV