Hey all,

I am compiling a second instance or lirc to control a cable box via Actisys200L device.  I am using 0.8.0pre1 and kernel 2.6.22.  I keep getting the same errors on make:

[root@mythtv remote-0.8.1pre1]# make
make  all-recursive
make[1]: Entering directory `/root/remote-0.8.1pre1'
Making all in drivers
make[2]: Entering directory `/root/remote-0.8.1pre1/drivers'
Making all in remote_dev
make[3]: Entering directory `/root/remote-0.8.1pre1/drivers/remote_dev'
Makefile:8: **************************************************
Makefile:8: *** Makefile trick not undone, trying to recover *
Makefile:8: **************************************************
mv Makefile.automake Makefile
make all
make[4]: Entering directory `/root/remote- 0.8.1pre1/drivers/remote_dev'
mv Makefile Makefile.automake
cp ../Makefile.kernel Makefile
make -C /usr/src/linux/ SUBDIRS=/root/remote-0.8.1pre1/drivers/remote_dev modules \
                KBUILD_VERBOSE=1
make[5]: Entering directory `/usr/src/linux-2.6.22'
test -e include/linux/autoconf.h -a -e include/config/auto.conf || (            \
        echo;                                                           \
        echo "  ERROR: Kernel configuration is invalid.";               \
        echo "         include/linux/autoconf.h or include/config/auto.conf are missing.";      \
        echo "         Run 'make oldconfig && make prepare' on kernel src to fix it.";  \
        echo;                                                           \
        /bin/false)
mkdir -p /root/remote-0.8.1pre1/drivers/remote_dev/.tmp_versions
rm -f /root/remote-0.8.1pre1/drivers/remote_dev/.tmp_versions/*

  WARNING: Symbol version dump /usr/src/linux- 2.6.22/Module.symvers
           is missing; modules will have no dependencies and modversions.

make -f scripts/Makefile.build obj=/root/remote-0.8.1pre1 /drivers/remote_dev
  gcc -m32 -Wp,-MD,/root/remote-0.8.1pre1/drivers/remote_dev/.remote_dev.o.d  -nostdinc -isystem /usr/lib/gcc/i386-redhat-linux/4.1.2/include -D__KERNEL__ -Iinclude  -include include/linux/autoconf.h -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Os -pipe -msoft-float -mregparm=3 -freg-struct-return -mpreferred-stack-boundary=2  -march=i586 -mtune=generic -mtune=generic -ffreestanding -maccumulate-outgoing-args -DCONFIG_AS_CFI=1 -DCONFIG_AS_CFI_SIGNAL_FRAME=1 -Iinclude/asm-i386/mach-generic -Iinclude/asm-i386/mach-default -fomit-frame-pointer -g  -fno-stack-protector -Wdeclaration-after-statement -Wno-pointer-sign -DIRCTL_DEV_MAJOR=72 -DEXPORT_SYMTAB -DHAVE_CONFIG_H -I. -I../.. -I/root/remote- 0.8.1pre1/drivers/remote_dev/../.. -I/usr/src/linux//include/  -DMODULE -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD_STR(remote_dev)"  -D"KBUILD_MODNAME=KBUILD_STR(remote_dev)" -c -o /root/remote- 0.8.1pre1/drivers/remote_dev/.tmp_remote_dev.o /root/remote-0.8.1pre1/drivers/remote_dev/remote_dev.c
/root/remote-0.8.1pre1/drivers/remote_dev/remote_dev.c:35:26: error: ./linux/config.h: Too many levels of symbolic links
/root/remote-0.8.1pre1/drivers/remote_dev/remote_dev.c:54:35: error: ./linux/devfs_fs_kernel.h: Too many levels of symbolic links
/root/remote-0.8.1pre1/drivers/remote_dev/remote_dev.c: In function 'cleanup':
/root/remote-0.8.1pre1/drivers/remote_dev/remote_dev.c:132: warning: implicit declaration of function 'devfs_remove'
/root/remote-0.8.1pre1/drivers/remote_dev/remote_dev.c: In function 'remote_register_plugin':
/root/remote-0.8.1pre1/drivers/remote_dev/remote_dev.c:381: warning: implicit declaration of function 'devfs_mk_cdev'
make[6]: *** [/root/remote-0.8.1pre1/drivers/remote_dev/remote_dev.o] Error 1
make[5]: *** [_module_/root/remote-0.8.1pre1/drivers/remote_dev] Error 2
make[5]: Leaving directory `/usr/src/linux-2.6.22'
make[4]: *** [remote_dev.o] Error 2
make[4]: Leaving directory `/root/remote- 0.8.1pre1/drivers/remote_dev'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/root/remote-0.8.1pre1/drivers/remote_dev'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/root/remote- 0.8.1pre1/drivers'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/remote-0.8.1pre1'
make: *** [all] Error 2



Can anyone advise or help? 

Thanks,
Bill