I'm following Jarod's guide for setting up mythtv on FC6.  I am having trouble getting lirc loaded.    I have taken these steps so far:  (Im using a PVR-250, new style grey/black remote)

# yum -y install lirc-kmdl-$KVER
(after running this it returned:
Parsing package install arguments
No Match for argument: lirc_i2c
Nothing to do
)
# yum -y install lirc
(this installed just fine- exact same suituation occured when installing ivtv)
# cp /usr/share/doc/lirc-*/remotes/hauppauge/lircd.conf.hauppauge /etc/lircd.conf

I then modified my modprobe.conf (I have been adding a bunch of different things to modprobe trying to get lirc and ivtv to load, so I'm not sure how much is actually needed/helping)  The entire contents of my modprobe are as follows:

alias char-major-61 lirc_i2c
alias eth0 forcedeth
alias scsi_hostadapter sata_nv
alias eth1 bcm43xx
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
options snd-intel8x0 index=0
remove snd-intel8x0 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
# ivtv modules setup
alias char-major-81 videodev
alias char-major-81-0 ivtv
# nvidia kernel module
alias char-major-195 nvidia-1_0-8776
alias nvidia nvidia-1_0-8776
install ivtv /sbin/modprobe --ignore-install ivtv; /sbin/modprobe ivtv-fb
install lirc_i2c /sbin/modprobe ivtv; /sbin/modprobe --ignore-install lirc_i2c
#not sure what this is, was told it might help?
alias tveeprom tveeprom-ivtv
alias msp3400 msp3400-ivtv

Then as per Jarod's guide I attempted to load lirc:

[root@localhost mythtv]# /sbin/depmod -a
[root@localhost mythtv]# /sbin/modprobe lirc_i2c
FATAL: Module lirc_i2c not found.
FATAL: Error running install command for lirc_i2c

As you can see some errors...

I have been trying all sorts of fixes, including trying to  download and install a lirc kernel driver (lirc-kmdl-2.6.18-1.2868.fc6-0.8.1-65_cvs20061130.fc6.at.i686.rpm ) however I have no idea if that is the right one to use, and when I attempted to "rpm -i" it said it needed lirc-devices.  So I went back and got lirc-devices from ATrpms, and installed it using rpm -i again.  Nothing happened so I continued to try to install the kernel driver again, same error.

Now it may be important to know that I had the same problem when trying to install ivtv a few hours ago.  Following Jarod's guide I went through the motions for ivtv and when I tried to load it I got "FATAL: Module ivtv not found."  This I later fixed by following the ivtv howto for FC6.  All this leads me to believe that yum is not getting the correct rpms?.. How do I fix this?  Even if i can't fix yum, how do I fix the lirc issue? 
Anything you can offer this linux noob would be great.  Thanks in advance.

-Aaron