Good day,

 

OK so I have managed to get my hands on a laptop with a builtin IR module using lirc_sir

 

I now believe everything is working fine i had to

 

Setserial /dev/ttyS0 uart none

 

Then modprobe lirc_sir and dmesg gave me this output:

 

lirc_dev: IR Remote Control driver registered, major 61

lirc_sir: I/O port 0x03f8, IRQ 4.

lirc_sir: Installed.

 

I have confirmed that /dev/lirc/0 does exist after the modprobe (this is good news as I could not get this far with lirc_mceusb2 on another systems with the MCE remote)

 

However irrecord gives me a “timeout” error and irw seems to “hang”

 

mode2 -d /dev/lirc/0 also gives me nothing

 

I am running mandriva and my /etc/sysconfig/lircd looks like this:

 

# Customized setings for lirc daemon

 

# The hardware driver to use, run lircd --driver=? for a list

 

DRIVER=default

 

# Hardware driver module to load

HWMOD=lirc_dev

 

# The device node that communicates with the IR device.

# if you are using lirc_serial, set DEVICE to /dev/ttyS[0-9]

# where 0-9 is the serial port your IR receiver is plugged

 

# with devfs enabled

DEVICE=/dev/lirc/0

#DEVICE=/dev/lirc/serial

 

# without devfs

#DEVICE=/dev/lirc

 

# Serial port for the receiver (for serial driver)

#COM1 (/dev/ttyS0)

#COM_PORT=/dev/ttyS0

#DRIVER_OPTS="irq=4 io=0x3f8"

 

#COM2 (/dev/ttyS1)

#COM_PORT=/dev/ttyS1

#DRIVER_OPTS="irq=3 io=0x2f8"

 

# COM3 (/dev/ttyS2)

#COM_PORT=/dev/ttyS2

#DRIVER_OPTS="irq=4 io=0x3e8

 

# COM4 (/dev/ttyS3)

#COM_PORT=/dev/ttyS3

#DRIVER_OPTS="irq=3 io=0x2e8"

 

I have also tried the lirc_serial modules (after rmmod lirc_sir of course) with the same results

 

My kernel version is 2.6.24.4 and lirc version is lirc 0.8.3

 

What seems to be the problem now I do not know (I have tried about 5 different remotes)

 

Kind Regards

Wayne Rolfe

Novicus Systems

T: 083 704 1624

F: 086 654 4043

E: wayne@novicus.com

W: http://www.novicus.com