Hello Team, 
I am able to install LIRC drivers on to board.
lirc_dev: IR Remote Control driver registered, major 61
lirc_mceusb: Windows Media Center Edition USB IR Transceiver driver for LIRC 1.90
But i tried starting lirc service
 /opt/canmore/local/sbin/lircd /etc/lircd.conf

But remote control does'nt seem to work at all, we find no logs ub /var/log/messages.
Please do help with this,
Thanks,
Rashmi 


On Fri, Nov 9, 2012 at 12:32 PM, endeavor john <jendeavor@gmail.com> wrote:
Hi Team ,
I am cross compiling the LIRC for CE4100 target.
I am using following config options :
export CONFIG_SITE=./canmore.config

./configure $DEBUG_OPTIONS --prefix=/opt/canmore/local --host=i686-cm-linux --with-kerneldir=/usr/local/Intel/IntelCE-21.4.11332.291760/project_build_i686/IntelCE/kernel-21.5.11393.297315/linux-2.6.35 --with-moduledir=/usr/local/Intel/IntelCE-21.4.11332.291760/project_build_i686/IntelCE/root/lib/modules --without-x --with-driver=mceusb
When i try to compile i get the following error:

make -f scripts/Makefile.build obj=/root/lirc/lirc-0.8.7/drivers/lirc_dev
  gcc -Wp,-MD,/root/lirc/lirc-0.8.7/drivers/lirc_dev/.lirc_dev.o.d  -nostdinc -isystem /usr/lib/gcc/i686-linux-gnu/4.6/include -I/usr/local/Intel/IntelCE-21.4.11332.291760/project_build_i686/IntelCE/kernel-21.5.11393.297315/linux-2.6.35/arch/x86/include -Iinclude  -include include/generated/autoconf.h -D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration -Wno-format-security -fno-delete-null-pointer-checks -O2 -m64 -mno-red-zone -mcmodel=kernel -funit-at-a-time -maccumulate-outgoing-args -DCONFIG_AS_CFI_SIGNAL_FRAME=1 -DCONFIG_AS_CFI_SECTIONS=1 -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -fno-stack-protector -fomit-frame-pointer -Wdeclaration-after-statement -Wno-pointer-sign -fno-strict-overflow -fconserve-stack -DIRCTL_DEV_MAJOR=61 -DEXPORT_SYMTAB -DHAVE_CONFIG_H -I. -I../.. -I/root/lirc/lirc-0.8.7/drivers/lirc_dev/. -I/root/lirc/lirc-0.8.7/drivers/lirc_dev/. -I/root/lirc/lirc-0.8.7/drivers/lirc_dev/../.. -I/root/lirc/lirc-0.8.7/drivers/lirc_dev/../.. -I/usr/local/Intel/IntelCE-21.4.11332.291760/project_build_i686/IntelCE/kernel-21.5.11393.297315/linux-2.6.35//include/ -I/usr/local/Intel/IntelCE-21.4.11332.291760/project_build_i686/IntelCE/kernel-21.5.11393.297315/linux-2.6.35//drivers/media/video/  -DMODULE -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD_STR(lirc_dev)"  -D"KBUILD_MODNAME=KBUILD_STR(lirc_dev)"  -c -o /root/lirc/lirc-0.8.7/drivers/lirc_dev/lirc_dev.o /root/lirc/lirc-0.8.7/drivers/lirc_dev/lirc_dev.c
cc1: fatal error: include/generated/autoconf.h: No such file or directorythe same.

Please let me know how to fix 
Thanks,
John