hi all,

got an issue with a mplay2 device (moncaso 312 usb ir receiver). I run openelec on that system and created a keymapping with irrecord. When I start lircd it run's fine and gives me all the keys I configured when I run irw and press some keys.
However, I would like to use that receiver via /dev/input/eventX as an input device and started lircd as such with -u. When I run evtest and select the lircd input device I see the keys I configured in lircd.conf (similar with irw). But, one key isn't forwarded or picked up. I mapped 0x42 as KEY_OK and it isn't shown in evtest and neither in cat /dev/input/eventX (lircd event device). When I remap KEY_OK to another key it is shown. When I map another key on code 0x42 it isn't shown either.

Kernel = 3.2.16. Lirc version = 0.90.

Can someone please help me out what to do on this issue, because it is the OK button on the remote and with XBMC that's quite an important key. Remapping to another button will not be accepted by wife and kids, and to be honest, I don't think I will like it very much myself.

Will run strace to start lircd tonight and try to find a cause for this. But perhaps someone can shine a light on this one and give me a lead or even a solution?

kind regards

Jouk

The single biggest problem in communication is the illusion that it has taken place.