On 14 April 2011 14:52, Rajesh Krishna Balan <rajesh@cs.cmu.edu> wrote:
On 14/4/2011 3:25 PM, Andrew Bowman wrote:


On 14 April 2011 02:31, Rajesh Krishna Balan <rajesh@cs.cmu.edu> wrote:
jumping in late here. I'm using the pvr150-mce as my capture card and the USB IR blast that MCE edition of the in ubuntu maverick.

I've attached my lirc files for reference. the drivers used are compiled manually using the current lirc git sources.

Hope it helps.

Rajesh


On 14/4/2011 4:04 AM, Andrew Bowman wrote:


On 13 April 2011 15:21, Jarod Wilson <jarod@wilsonet.com> wrote:
On Apr 13, 2011, at 6:51 AM, Andrew Bowman wrote:

> On 10 April 2011 19:02, Andrew Bowman <andbow@gmail.com> wrote:
...
> Yippee ! †50% there, †now get an output from IRW which I am very happy with. †However I am unsure if the blaster is working yet. There are no transmitter devices in the harwdware.conf

hardware.conf is a debianism, not an upstream lirc thing. The
separate TRANSMITTER crud is a relic from the days of needing
two separate pieces of hardware and two separate drivers and
lircd instances in order to transmit. The mceusb is a single
device, capable of handling both, so that stuff is just plain
misleading and confusing. I'd advise removing anything and
everything under TRANSMITTER there, and only set up the other
section.


> #Chosen IR Transmitter
> TRANSMITTER="Microsoft Windows Media Center V2 (usb) : Direct TV Receiver"
> TRANSMITTER_MODULES="lirc_dev mceusb"
> TRANSMITTER_DRIVER=""
> TRANSMITTER_DEVICE=""
> TRANSMITTER_SOCKET=""
> TRANSMITTER_LIRCD_CONF="directtv/general.conf"
> TRANSMITTER_LIRCD_ARGS="
>
> When I try †IRSEND
>
> andrew@DVRBOX:~$ irsend SEND_ONCE directtv 101
> irsend: command failed: SEND_ONCE directtv 101
> irsend: hardware does not support sending
> andrew@DVRBOX:~$

Not quite sure what's going on there, but I mostly blame it on
the obtuseness of hardware.conf at this point.


> Some more info
>
> andrew@DVRBOX:~$ irsend LIST directtv ""
> irsend: 0000000000000001 1
> irsend: 0000000000000002 2
> irsend: 0000000000000003 3
> irsend: 0000000000000004 4
> irsend: 0000000000000005 5
> irsend: 0000000000000006 6

Those don't look like valid IR scancodes to me.

http://lirc.sourceforge.net/remotes/directv/


> I can on guess that there is still some PEBKAC error in my config.
>
> Andrew
>
>
> This is so frustrating, I have googled till my fingers bled but still I am not sure of a solution. I just don't know how I would configure a device for blasting

It should be dead-simple for mceusb devices, but hardware.conf makes what
should be perfectly straight-forward incredibly obtuse. Would be really
nice if the debian/ubuntu/whoever lirc package maintainers would do
something about it, because its bit quite a few users now.


--
Jarod Wilson
jarod@wilsonet.com


No luck ... I have tried commenting out and then removing all under TRANSMITTER , still get the irsend: hardware does not support sending message.† The IR Scancodes are OK (I think) copied them from my old mythbox, I have a non std STB.
Andrew

------------------------------------------------------------------------------ Benefiting from Server Virtualization: Beyond Initial Workload Consolidation -- Increasing the use of server virtualization is a top priority.Virtualization can reduce costs, simplify management, and improve application availability and disaster protection. Learn more about boosting the value of server virtualization. http://p.sf.net/sfu/vmware-sfdev2dev

Hi Rajesh,
Thanks for your input, please tell me what you get when you do a
ls /dev/lirc*
Andrew

ls -l /dev/lirc*
crw------- 1 root root 250, 0 2011-04-03 03:47 /dev/lirc0
crw------- 1 root root 250, 1 2011-04-03 03:47 /dev/lirc1
lrwxrwxrwx 1 root root†††† 19 2011-04-03 03:47 /dev/lircd -> /var/run/lirc/lircd
lrwxrwxrwx 1 root root†††† 20 2011-04-03 03:47 /dev/lircd1 -> /var/run/lirc/lircd1

ps axwww | grep -i lir
† 369 pts/1††† S+†††† 0:00 grep -i lir
†1524 ?††††††† Ss†††† 0:20 /usr/sbin/lircd --output=/var/run/lirc/lircd --device=/dev/lirc0 --listen
†1534 ?††††††† Ss†††† 0:00 /usr/sbin/lircd --output=/var/run/lirc/lircd1 --device=/dev/lirc1 --connect=localhost 8765 --pidfile=/var/run/lirc/lircd1.pid
†1543 ?††††††† Ss†††† 0:00 /usr/bin/irexec -d /etc/lirc/lircrc
†1990 ?††††††† Ss†††† 0:00 /usr/bin/irexec -d /etc/lirc/lircrc

Rajesh


I donít know if I am barking up the wrong tree here but I with my very limited linux knowledge I think this is a device problem. I have seen this on the lirc site and thought I might give it a go

http://www.lirc.org/html/configure.html

If you want to use more than one device that uses a kernel module you should now have a look at the character device setup in /dev/. Each LIRC kernel module provides a device with major number 61 and a minor number beginning at 0 which is counted up every time a new driver is loaded (note: both the major number and the minor number concept are subject to change in future LIRC releases). If you want to use two devices then the LIRC related files in /dev/ should look something like this (this might be done automatically if you are using devfs or sysfs):

> ls -l /dev/lirc*

crw-r--r--††† 1 root†††† root††††† 61,†† 0 Apr 252001 /dev/lirc

crw-r--r--††† 1 root†††† root††††† 61,†† 1 Nov6 19:24 /dev/lirc1

You can create new entries by running:

> mknod /dev/lirc2 c 61 2

For each device you want to use you have to start an individual lircd instance. If you want to receive events from all receivers at one socket interface you have to connect the different lircd interfaces with an additional TCP/IP socket. This could look e.g. like this:

> lircd --driver=default --device=/dev/lirc1 --output=/var/run/lirc/lircd1 \

††† --pidfile=/var/run/lirc/lircd1.pid --listen

> lircd --driver=default --device=/dev/lirc --output=/var/run/lirc/lircd \

††† --pidfile=/var/run/lirc/lircd.pid --connect=localhost:8765

All events will now be visible at /var/run/lirc/lircd. The second lircd instance connects to the first instance using a TCP/IP socket. The default port is 8765. It can be changed by providing an optional parameter to the --listen switch. If you have more lircd instances you want to connect to, you can provide multiple --connect parameters to the last lircd instance. Please note that lircd will not relay events received from one lircd to another. So you can't daisy-chain lircds. Instead you need a star topology setup

andrew@DVRBOX:~$ ls -l /dev/lirc*

lrwxrwxrwx 1 root root 19 2011-04-14 08:15 /dev/lircd -> /var/run/lirc/lircd

so I presume I do a

andrew@DVRBOX:~$ sudo mknod /dev/lirc1 c 19 2

which now gives me

andrew@DVRBOX:~$ ls -l /dev/lirc*

crw-r--r-- 1 root root 19, 2 2011-04-14 16:46 /dev/lirc1

lrwxrwxrwx 1 root root††† 19 2011-04-14 08:15 /dev/lircd -> /var/run/lirc/lircd

which doesnít look right and I donít really understand how to do the -> /var/run/lirc/lircd or would it be lirc1† and the permissioning is also different.

As for the rest ....