On 8 April 2011 17:41, Jarod Wilson <jarod@wilsonet.com> wrote:
On Apr 8, 2011, at 11:15 AM, Andrew Bowman wrote:

> The basic approach fails with
>   CC [M]  /home/andrew/media_build/v4l/timblogiw.o
> /home/andrew/media_build/v4l/timblogiw.c: In function 'timblogiw_probe':
> /home/andrew/media_build/v4l/timblogiw.c:794: error: implicit declaration of function 'mfd_get_data'
> /home/andrew/media_build/v4l/timblogiw.c:794: warning: initialization makes pointer from integer without a cast
> make[3]: *** [/home/andrew/media_build/v4l/timblogiw.o] Error 1
> make[2]: *** [_module_/home/andrew/media_build/v4l] Error 2
> make[2]: Leaving directory `/usr/src/linux-headers-2.6.35-28-generic'
> make[1]: *** [default] Error 2
> make[1]: Leaving directory `/home/andrew/media_build/v4l'
> make: *** [all] Error 2
> *** ERROR. Aborting ***

I hate that driver... You can edit v4l/Makefile.media, and just comment
out anything related to CONFIG_*_TIMBERALE, but ultimately, we'll need
to patch up media_build to fix that. Its occasionally a losing battle
trying to keep media_build working...

Jarod Wilson

Yippee !  50% there,  now get an output from IRW which I am very happy with.  However I am unsure if the blaster is working yet. There are no transmitter devices in the harwdware.conf
#Chosen IR Transmitter
TRANSMITTER="Microsoft Windows Media Center V2 (usb) : Direct TV Receiver"
TRANSMITTER_MODULES="lirc_dev mceusb"
When I try  IRSEND
andrew@DVRBOX:~$ irsend SEND_ONCE directtv 101
irsend: command failed: SEND_ONCE directtv 101
irsend: hardware does not support sending
Some more info
andrew@DVRBOX:~$ irsend LIST directtv ""
irsend: 0000000000000001 1
irsend: 0000000000000002 2
irsend: 0000000000000003 3
irsend: 0000000000000004 4
irsend: 0000000000000005 5
irsend: 0000000000000006 6
I can on guess that there is still some PEBKAC error in my config.