Hi, I had LIRC working super before, but am on a fresh install of Arch linux and am trying to get it going again. Whenever I start the /etc/rc.d/lircd daemon, it gets killed if I run irw or irexec, both giving "connection refused" errors when run. Here's some dmesg output:

"lirc_dev: IR Remote Control driver registered, major 61
lirc_serial: port 03f8 already in use
lirc_serial: use 'setserial /dev/ttySX uart none'
lirc_serial: or compile the serial port driver as module and
lirc_serial: make sure this module is loaded first
sysfs: duplicate filename 'lirc_serial.0' can not be created
------------[ cut here ]------------
WARNING: at fs/sysfs/dir.c:424 sysfs_add_one+0xb7/0xe0()
Modules linked in: lirc_serial(+) lirc_dev isofs zlib_inflate udf loop nfs lockd nfs_acl sunrpc cifs ipv6 coretemp w83627ehf hwmon_vid ohci1394 ieee1394 firewire_ohci firewire_core i2c_i801 ppp_generic nvidia(P) intel_agp usb_storage crc_itu_t pcspkr agpgart i2c_core sg thermal processor evdev fan button battery ac usbhid hid ff_memless snd_ice1724 snd_ice17xx_ak4xxx snd_ac97_codec snd_pt2258 snd_i2c snd_ak4xxx_adda snd_ak4114 snd_mpu401_uart snd_rawmidi snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_pcm snd_timer snd_page_alloc snd_mixer_oss snd soundcore ac97_bus slhc sky2 rtc_cmos rtc_core rtc_lib ext3 jbd mbcache sr_mod cdrom sd_mod ehci_hcd uhci_hcd usbcore ata_piix ahci ata_generic pata_jmicron pata_acpi libata scsi_mod dock
Pid: 18764, comm: modprobe Tainted: P         2.6.25-ARCH #1
 [<c0128e9f>] warn_on_slowpath+0x5f/0xa0
 [<c011f713>] __wake_up_common+0x43/0x70
 [<c0123aae>] __wake_up+0x3e/0x60
 [<c01295b3>] wake_up_klogd+0x33/0x40
 [<c019945e>] find_inode+0x3e/0x70
 [<c01caf60>] sysfs_ilookup_test+0x0/0x10
 [<c01995a6>] ifind+0x46/0xa0
 [<c01cb407>] sysfs_add_one+0xb7/0xe0
 [<c01cb9b8>] create_dir+0x48/0x90
 [<c01cba29>] sysfs_create_dir+0x29/0x50
 [<c01f70ff>] kobject_get+0xf/0x20
 [<c01f723d>] kobject_add_internal+0xbd/0x1b0
 [<c01f73a8>] kobject_set_name_vargs+0x28/0x40
 [<c01f747d>] kobject_add+0x2d/0x60
 [<c01f70ff>] kobject_get+0xf/0x20
 [<c025d359>] device_add+0xb9/0x570
 [<c0261145>] platform_device_add+0x135/0x180
 [<f8a2c02a>] init_module+0x2a/0x2a9 [lirc_serial]
 [<c014eda8>] sys_init_module+0x148/0x1bf0
 [<f88e5d7c>] journal_stop+0x14c/0x1d0 [jbd]
 [<c0170ee0>] arch_get_unmapped_area_topdown+0x0/0x180
 [<f8ce3e60>] lirc_register_plugin+0x0/0x520 [lirc_dev]
 [<c0109610>] sys_mmap2+0xd0/0xe0
 [<c01050d8>] sysenter_past_esp+0x6d/0xa5
 =======================
---[ end trace 3495bf2dcfe575af ]---
kobject_add_internal failed for lirc_serial.0 with -EEXIST, don't try to register things with the same name in the same directory.
Pid: 18764, comm: modprobe Tainted: P         2.6.25-ARCH #1
 [<c01f7282>] kobject_add_internal+0x102/0x1b0
 [<c01f747d>] kobject_add+0x2d/0x60
 [<c01f70ff>] kobject_get+0xf/0x20
 [<c025d359>] device_add+0xb9/0x570
 [<c0261145>] platform_device_add+0x135/0x180
 [<f8a2c02a>] init_module+0x2a/0x2a9 [lirc_serial]
 [<c014eda8>] sys_init_module+0x148/0x1bf0
 [<f88e5d7c>] journal_stop+0x14c/0x1d0 [jbd]
 [<c0170ee0>] arch_get_unmapped_area_topdown+0x0/0x180
 [<f8ce3e60>] lirc_register_plugin+0x0/0x520 [lirc_dev]
 [<c0109610>] sys_mmap2+0xd0/0xe0
 [<c01050d8>] sysenter_past_esp+0x6d/0xa5
 ======================="



I have a working /etc/lircd.conf and ~/.lircrc from before. Just can't get it to go though. Any help greatly appreciated!!

Bobby