On 11/10/05, Michael Mauch <michael.mauch@gmx.de> wrote:
MacNean Tyrrell wrote:

> I just bought one of those packard bell remote cheap off ebay. I'm having a
> problem getting it to work. Here is the output if i run irw:
> root@mythtvbox2:~# lircd --nodaemon
> lircd 0.7.2: lircd(serial) ready
> lircd 0.7.2: accepted new client on /dev/lircd
> lircd 0.7.2: could not get hardware features
> lircd 0.7.2: this device driver does not support the new LIRC interface
> lircd 0.7.2: major number of /dev/lirc is 4
> lircd 0.7.2: LIRC major number is 61
> lircd 0.7.2: check if /dev/lirc is a LIRC device
> lircd 0.7.2: caught signal
> Terminated
> (I have also install lirc with the packard bell option so the second line
> has that instead of (serial) but both do the same thing)
> I do have ln /dev/ttyS0 /dev/lirc

Why? That's wrong. /dev/lirc/0 or /dev/lirc0 should be the lirc output

crw-rw----  1 root root 61, 0  9. Nov 10:19 /dev/lirc/0

It should be created automatically by the lirc_dev kernel module, which
is loaded automatically if you modprobe lirc_serial.

You're right it was wrong i figured it out yesterday.  See i was using KnoppMyth.  This is for my frontend.  I have pvr-250's in my backend so i knew how to get lirc running with that no problem.  I had installed the frontend before receiving the serial receiver off ebay.  When i plugged it in and recompiled lirc and such, it didn't overwrite the /dev/lirc that was already there.  So no matter how much i ran setserial and modprobe lirc_serial and make install of lirc, it wouldn't work.  And when i did delete /dev/lirc i kept linking it myself to /dev/ttyS0, which has a major number of 4, not 61.  So after a lot of searching, i read the mythtv instructions for lirc, and it said make install should create /dev/lirc automatically for you.  So i deleted all /dev/lirc* reran make install and it worked.

Be sure to use

  setserial /dev/ttyS0 uart none

(or /dev/ttyS1 if that's your serial port for lirc) before you load the
lirc_serial module.

The lirc device type, port and IRQ are set with parameters of
lirc_serial, e.g.

  modprobe lirc_serial type=1 io=0x2f8 irq=3

See "modinfo lirc_serial" for more options (especially the type).

> I also have linked S1 to lirc0 and ran lircd with the device option to
> lirc0.

That's also wrong.

> Can anyone help?

Perhaps somebody could give specific help for your distribution if you
would write which distribution you are using.


SF.Net email is sponsored by:
Tame your development challenges with Apache's Geronimo App Server. Download
it for free - -and be entered to win a 42" plasma tv or your very own
Sony(tm)PSP.  Click here to play: http://sourceforge.net/geronimo.php


MacNean C. Tyrrell