OK, so I re-imaged by installation (image taken right before any LIRC stuff) and did the pure CVS approach.  After sudo make install, I run:
 
"modprobe lirc_imon"
 
I then examine the /etc/lirc/lircd.conf file and it is for the iMON remote, so I replace it with lircd.conf.imon-mceusb and call it lircd.conf.  I then see that there is no hardware.conf file so I create one and point lircd to the new conf file I created above.  At this point I don't think that lircd is actually running as I don't see any lirc* when running:
 
"ps -a"
 
I go to /usr/local/sbin and run:
 
"sudo lircd --device=/dev/lirc0"
 
but it errors out saying:
 
"lircd: can't open or create /var/run/lirc/lircd.pid
lircd: No such file or directory"
Plus I can't run IRW from /usr/local/bin as it errors out with similar output.  I'm guessing I need to get lircd running somehow, but I am not sure.  In /dev/ I only have lirc0, shouldn't I also need lirc?  Also you said that I need to add the parameter ir_protocol=1 to the imon driver, so how do I do that?
 
Sorry for the questions, but this has been frustrating me for about a week now.  It doesn't help that I am re-aquainting myself with Linux after 10+ years of Windows.
 
 
 
Thanks,
Lee


From: Jarod Wilson [mailto:jarod@wilsonet.com]
Sent: Wed 7/29/2009 9:51 PM
To: Nugent, Lee
Cc: lirc-list@lists.sourceforge.net
Subject: Re: MCE Remote and iMON Reciever

On 07/29/2009 05:00 PM, Lee Nugent wrote:
> OK, so I have another problem then.  Once I couldn't get 8.0.4a working
> with my MCE remote, I decided to build LIRC from CVS following this
> procedure:
>
> sudo apt-get install cvs build-essential dialog libtool automake
> autoconf
>
> cvs -d:pserver:anonymous@lirc.cvs.sourceforge.net:/cvsroot/lirc login
> cvs -z8 -d:pserver:anonymous@lirc.cvs.sourceforge.net:/cvsroot/lirc co
> lirc
> cd lirc
> ./autogen.sh
> ./setup.sh
>
> Selected Soundgraph IR/LCD when prompted.
>
> Make
> Sudo make install
> Sudo dpkg-reconfigure lirc-modules-source
>
> But I get the following error:
>
> Removing all DKMS Modules
> Done.

Having both the dkms builds *and* cvs builds at the same time is bound
to lead to problems. I suspect your "removing all dkms modules" bit
there may have undone the 'sudo make install' you did from cvs earlier,
as if I recall correctly, the ubuntu dkms stuff puts the modules in the
same place lirc cvs's make install does...


> Adding Module to DKMS build system
> Doing initial module build
>
> Error!  Build of lirc_imon.ko failed for: 2.6.28-13-generic (i686)
> Consult the make.log in the build directory
> /var/lib/dkms/lirc/0.8.4a/build/ for more information.
> Installing initial module
>
> Error! Could not locate lirc_atiusb.ko for module lirc in the DKMS tree.
> You must run a dkms build for kernel 2.6.28-13-generic (i686) first.
> Done.
>
> The above is specifig to Ubuntu I guess so I just tried:
>
> Sudo modprobe lirc_imon
>
> But then when I try to run IRW it says it can't be found.
>
> I am missing something very easy apparently.

Get rid of the dkms stuff for now, remove lirc-module-sources, and only
work with lirc cvs.


> -----Original Message-----
> From: Jarod Wilson [mailto:jarod@wilsonet.com]
> Sent: Wednesday, July 29, 2009 3:20 PM
> To: Nugent, Lee
> Cc: lirc-list@lists.sourceforge.net
> Subject: Re: MCE Remote and iMON Reciever
>
> On Jul 29, 2009, at 3:40 PM, Lee Nugent wrote:
>
>> I am running a fresh copy of Ubuntu Jaunty and installed LIRC via:
>>
>> sudo apt-get install LIRC
>>
>> which installed version 8.0.4a.  During the install, I chose
>> Soundgraph
>> IR/LCD when prompted as I have the ffdc version shown when running:
>>
>> sudo lsusb
>>
>> Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
>> Bus 004 Device 002: ID 15c2:ffdc SoundGraph Inc. iMON PAD Remote
>> Controller
>> Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
>> Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
>> Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
>>
>> I ran IRW and used the iMON remote but no output was displayed.  I
>> then
>> looked in /etc/lirc/lircd.conf and noticed that the file pointed to:
>>
>> Include "/usr/share/lirc/remotes/imon/lircd.conf.imon"
>>
>> This file had incorrect codes for my remote.  I then examined the
>> lircd.conf.imon-pad file and it contained the correct codes so I
>> changed
>> the include path in /etc/lirc/lircd.conf.  Now when I run IRW and
>> press
>> buttons on the iMON remote I see the correct output.  The only thing
>> that doesn't work is the soft directional pad in the middle of the
>> remote, but that doesn't matter at this point as using the iMON remote
>> is not my end game.
>
> And its not the lirc project's fault, its ubuntu that did that
> incorrectly for you. If you wish to see that resolved, file a bug in
> launchpad.
>
>
>> The end game is to use an MCE remote with the iMON receiver.  I have 4
>> XBMC HTPC's around the house and they are all using an MCE USB dongle
>> with an MCE remote and everyone in the house already knows how to use
>> them.  So I ran IRRECORD and followed all the instructions using my
>> MCE
>> remote.  Copied the new lircd.conf file to /etc/lirc and edited the
>> hardware.conf file to look at /etc/lirc/lircd.conf for the config.
>> Restarted LIRC and ran IRW.
>>
>> Big problems!
>>
>> For example, when I press Play, the output shows Stop, then Red, then
>> Blue.  Basically, for every one button press I get anywhere from 1
>> to 3
>> responses (all recognized as 00 so not repeat commands) where all are
>> usually incorrect for the button pressed.  I have scoured the net
>> looking for others that have this problem, but can't find a single
>> one.
>
> Yeah, you're Doing It Wrong. :) The iMON devices do onboard decoding
> of IR signals, they can't be used with just any device. Current lirc
> cvs, the imon driver *does* support mce remotes though. You have to
> load the lirc_imon driver (built from cvs) with the parameter
> 'ir_protocol=1', otherwise its in standard iMON IR mode, and you need
> to use the imon-mceusb lircd.conf, also in lirc cvs. What you're
> running now ONLY supports using remotes talking the iMON's IR protocol.
>