I am running Debian Unstable, kernel 2.6.32.11 with lirc and lirc-modules-source version (0.8.6-1~c0.sidux.13). This was done in order to be able to compile lirc under the kernel.

This is the card in question - http://www.comprousa.com/en/product/k200/k200.html

lsusb reports it as follows:
Bus 003 Device 002: ID 185b:3020 Compro

So when I installed I decided to try modprobe lirc_mceusb2. lsmod reports

# lsmod | grep mce
lirc_mceusb            11881  0
lirc_dev                9749  1 lirc_mceusb
usbcore               137017  5 lirc_mceusb,usbhid,ohci_hcd,ehci_hcd

However there is no lircd.conf file for the remote. So I tried to do an irrecord -d /dev/lirc0 ~/k200.txt
I run the through the process but then get to a part where it keeps on asking me to enter the key for the NEXT button. The longest I've gone on this loop is 10 times. So eventually the k200.txt file ends up looking something like:

# Please make this file available to others
# by sending it to <lirc@bartelmus.de>
#
# this config file was automatically generated
# using lirc-0.8.6(default) on Fri Apr  9 20:28:29 2010
#
# contributed by
#
# brand:                       /root/k200.txt
# model no. of remote control:
# devices being controlled by this remote:
#

begin remote

  name  /root/k200.txt
  bits            0
  flags RC6|CONST_LENGTH
  eps            30
  aeps          100

  header       2718   707
  one           518   387
  zero          518   387
  pre_data_bits   37
  pre_data       0x37FF07BDE
  gap          108045
  toggle_bit_mask 0x8000
  rc6_mask    0x100000000

      begin codes
          KEY_NEXT                 0x0
          KEY_NEXT                 0x0
          KEY_NEXT                 0x0
      end codes

end remote

Any ideas on what I am doing wrong and how I can generate this file properly?

Thanks
Jongi