Laura, since you're running Ubuntu you might want to try my Ubuntu package for 0.8.6.  It makes life much easier :)

1. Go here: https://launchpad.net/~jyoder/+archive/ppa
2. Follow the Read about installing instructions
3. Run Synaptic and select lirc-modules-source and lirc packages
4. Apply
5. At a Terminal window prompt:  sudo dpkg-reconfigure lirc
6. Reboot

Let me know if you have any problems!
Jeremy


Laura Donovan Bannister wrote the following on 9/18/2009 10:31 AM:
Hi Christoph,

I changed the toggle_bit_mask to 0x800, but the behavior is still the same. There is no /dev/lirc file, and so that's why I tried using /dev/lircd:

# ls -ld /dev/lir*
srw-rw-rw- 1 root root 0 2009-09-18 09:28 /dev/lircd
#

I'm going to try compiling the new version of lirc from source to see if that resolves the issue.

Thanks for your help!

-LDB

> Try changing toggle_bit_mask to 0x800.

> You need to run mode2 with /dev/lirc, not /dev/lircd. You have to stop
> lircd before doing this.

> Christoph

------------------------------------------------------------------------------ Come build with us! The BlackBerry® Developer Conference in SF, CA is the only developer event you need to attend this year. Jumpstart your developing skills, take BlackBerry mobile applications to market and stay ahead of the curve. Join us from November 9-12, 2009. Register now! http://p.sf.net/sfu/devconf