<snip>
(My reply got bounced from the list for my message being too large, so I cut everything above out.  My apologies to anybody getting this twice, but I didn't want to remove Jarod or Patrick's private addresses or they may miss future replies.  Sorry again)
<snip>

I've had some trouble here too.  I accidentally replied privately to Jarod, so here's a quick transcript:

me:
====
It is better, but still no go for me.  With cvs post-Jarod's-patch (lirc_mceusb.c version 1.46) my emitter lights up (using transmitter port 2) when told to by irsend, but the cable box seems oblivious to it.  I'm using the same remote configuration (SAE8000) that worked for me with a serial blaster, and irw shows that the gen1 is interpreting the cable box remote's transmissions fine so I don't think it's a configuration issue.


Please let me know if there's anything I can do to help debug-wise.


Jarod:
======
The range of the transmitter is VERY short. If it wasn't just so, the other mceusb transceiver wouldn't pick up squat. It had to be right on the money. Oh, you may also need 'min_repeat 2' added to your transmit remote config bits in lircd.conf.

Me:
=======
I was pretty much right on top of the sensor so I don't think it's a range thing (that was my first thought too).  I'm using the "stock" scientificatlanta/general.conf SAE8000 config... I just checked it and there's no min_repeat in there, so that's definitely something to try.

I'll try the min_repeat first and then loop irsend and move the sensor around a bit to see if I get any life.