Hi Christoph, thanks for your reply!

Just grabbed today's CVS and it only slightly works. The first 'OK' came through irw, but nothing after that.

Output from lircd -D255 -n -d /dev/lirc0: http://pastebin.com/f40af106e ('OK', then a bunch of random presses)
Output from mode2 with a single 'OK', then a pause, then auto-repeated 'OK' presses: http://pastebin.com/f6f49db1d

After these runs, I started lircd and irw again, but pressing 'OK' once yielded nothing at all. That output, if you're interested, is here:
http://pastebin.com/f333e2294 To my untrained eyes, it looks pretty much like my first attempt from yesterday.

Note that I didn't reboot between lirc builds. After building and installing from CVS, I just did "rmmod lirc_streamzap lirc_dev" and modprobed them again.

(By the way, let me know if you need to continue seeing mode2 dumps.)

Thanks for your help, I'm ready to try anything you suggest.


On Mon, 2009-02-23 at 20:59 +0100, Christoph Bartelmus wrote:

Steve Freitas "sflist@ihonk.com" wrote:
> I've had trouble getting the remote working using the Ubuntu (kernel
> 2.6.27, 32-bit i686) lirc package, so I installed lirc from the latest
> Output from lircd -D255 -n -d /dev/lirc0: lircd:
> http://pastebin.com/f477b30b9

The timeout in line 173 is the problem. But currently I don't have any  
idea what causes it. Can you try again if it still happens with todays CVS  


Open Source Business Conference (OSBC), March 24-25, 2009, San Francisco, CA
-OSBC tackles the biggest issue in open source: Open Sourcing the Enterprise
-Strategies to boost innovation and cut costs with open source participation
-Receive a $600 discount off the registration fee with the source code: SFAD