( sorry versions are 0.8.0 and 0.8.1 respectively not 8.0.0 and 8.0.1)


I have indeed tried ... most everything

Looks like the change in the kernel serial happened somewhere after 2.6.14-r5, LIRC is broken in 2.6.15 and 2.6.16 revs

I tried the 8.0.0. ebuild no go , I also tried the 8.0.0 source and the CVS (8.0.1), all with the same result

BTW really useful to add '-enable-debug' to the LIRC_OPT in your make  debugging made easier.
I duplicated the process on my desktop (2.6.14-r5) and all is well from ebuild and sources, every time I do a raw cat on the serial I get the data, Lirc just doesnt get it ( cat /dev/ttyS0 | hexdump )

-Pete Flaherty


On Sat, 2006-04-29 at 12:26 +0200, Matthias Schwarzott wrote:
On Saturday 29 April 2006 09:41, Pete Flaherty wrote:
> Same problem here, Gentoo 2.6.16-r3
>
> Tried everything from packages to source and CVS ... No go
>
> Looks like it may be a serial port issue/change in the kernel, as I get
> Exactly 1 recognized keypress out of my mp3remote, then she stops
>
> Any body have any details ??? Ideas
>
Do you have tried the lirc-0.8.0 ebuild?

Matthias