I have built a IR transmitter as described on one of the links on the LIRC homepage. The receiver part of the circuit works well and my programs work well with it. But the transmitter part does not seem to work.

 

I’m confident that I’ve built the circuit correctly, so it should be a LIRC problem.

 

I’ve tried using the built-in LIRC version (0.7.0) that comes with SuSe 9.3 without success. It says that the hardware does not support sending when I use irsend.

 

I’ve also tried building my own (latest version from LIRC website) using the following options:

 

./configure –with-transmitter=yes –with-device=serial

./configure –with-transmitter=yes –with-device=com1

And by using the graphical interface (./configure without options)

 

In these cases nothing happens at all when I type:

# setserial /dev/ttyS0 uart none

# modprobe lirc_serial

# lircd

# irw

 

When I try IRRecord it says that “could not open /dev/lirc” and “no such device”.

 

Since the receiver part works well, I assume that my lirc.conf file is correct (but that shouldn’t matter at this stage, should it?)

 

Any suggestions or hints would be most appreciated, since I’ve been working on this problem for quite some time now.

 

Thanks,

Stefan