I had a problem where the receiver diode I was using wasn’t the right kind. When I got the faster version it was able to see the events. This was for a TV remote so it may be different.

 

From: Alec Leamas [mailto:leamas.alec@gmail.com]
Sent: Wednesday, May 14, 2014 9:46 AM
To: lirc-list@lists.sourceforge.net
Subject: Re: No dots printed when pressing the remote

 

 


On 2014-05-14 04:46, Jiechao Li wrote:

Hi, Joel

 

I tried with NEC.conf, but it still does not work. When I press the remote, it says 'Something went wrong. Please try again.'

 

I guess it's not the right protocol.

 

Jiechao

 

On Wed, May 14, 2014 at 10:08 AM, Joel Ebel <lirc@ebel.mybox.org> wrote:

On Tue, May 13, 2014 at 8:44 PM, Jiechao Li <jiechao0520@gmail.com> wrote:

Hi, 

 

Thanks for your reply. I am sure it is a IR remote. And I think the problem is that the IR codes is too long. I tried to force the remote mode for my this remote, but I don't know the right format for config file.

 

That looks like the NEC protocol. Start with the generic/NEC.conf file try irrecord again.

 


That might indeed mean that irrecord does not recognize the protocol. If nothing else works you should be able to get the raw codes using the --force option to irrecord (see manpage). Have you tried that?


--alec