Hi all,
 
Installed Lirc0.6.6.  setup.sh / configure / make / make install - all went fine w/o a hitch.  I have the Creative Infra Receiver recommended by another poster plugged into my serial port.  In the config, I chose that device under "other serial port devices" and picked com1 and default irq/io address.  Copied the config files for creative into place and set the permission on the dev/lircd.  Lircd runs fine.  However, when I run irw (or irrecord) that's where things go south!
 
When I run irw it kills the lircd daemon.  It's easiest to see this by opening up another console and firing up lircd -n (no daemon).  Then it just waits there patiently for a signal (and outputs debug msgs).  On the other console I run irw and it instantly ends (instead of staying there spitting out codes).  Switching back to the first (lircd) console I see this output:
 
[root@p800 tools]# lircd -n
lircd 0.6.6: lircd(creative) ready
lircd 0.6.6: accepted new client on /dev/lircd
lircd 0.6.6: could not open /dev/lirc
lircd 0.6.6: creative_init(): No such device
lircd 0.6.6: caught signal
Terminated
Here's how a ll of my lirc* devices look:
 
crw-rw-rw-    1 root     root      61,   0 Jan 15 05:08 /dev/lirc
srw-rw-rw-    1 root     root            0 Jan 31 01:16 /dev/lircd=
prw-r--r--    1 root     root            0 Jan 30 04:48 /dev/lircm|
 
(excuse my Lignorance, but what's the "=" sign at the end of the lircd line mean?  Is that a clue?)
Can those that got this working out there tell me if I did anything wrong please?  According to the configure instructions, I did _NOT_ need to modify the serial support in the kernel, or "alias char-major-61 XXX"  - right?  Nor should I do the modprobe lirc_serial or ldconfig, right?   I uninstalled and reinstalled twice - same result.
 
Anyway, I think if I can get it to "listen" with IRW or IRRECORD talking to it then I'll be in business. My remote and receiver ARE on the list so they should work.  I checked BIOS and COM1 is Auto enabled and I tried manual also.  I also tried recompiling the kernel with serial support as a module - no diff.  Oh, one more clue... When I tried it as a standard RS232 device (instead of creative) it DID sit there happily when I ran IRW (LIRCD didn't blow up) but IRW never output any codes.  Does that mean /dev/lircd is ok then or what? 
 
Thanks!
JC