Hi all,

I'm sorry, I am just too much of a "newbie" to understand what I need to do
to get this creative infra receiver to work.  Can somebody who has it
working please answer these questions?  Thanks!

1) What do you have compiled in your kernel for it - (Y/M/None - for
serial/irda/etc).

2) Do you have an alias char-major-61 lirc_serial (or just serial) as the
1st line of /etc/modules.conf?  I think this is failing for me.  I certainly
can't type it on the bash cmd line. (I get char-major-61 not found and
lirc_serial not found).   Should I be able to type it at the cmd line?  Can
you?

3) What exactly should we have for the /dev/lirc* devices?  Do a ls -l for
us please?
    a) dev/lirc - with type char 61,0 and  mod 666?
    b) Should we do a 'ln -sf /dev/ttyS0 /dev/lirc' ?  If so, this changes
it to type 10 then right?
    c) dev/lircd ? If so, what permissions and type?
    d) dev/lircm ? Same questions

4) Should we be replacing lirc_serial with serial.o from the daemons
directory or something?  Where/How?  Should

5) What modules should we be loading (I assume lircd) and WHEN should it be
loaded.

6) What about the lircd.conf file?  Should we use the   lircd.conf.creative
in the remotes/creative subdirectory under the 0.6.6 folder?  What about the
one in the remotes tar file?  In there there's a creative directory with CD,
CD.old and RM-900.irman?

Here's what would be ideal... Just give us a string of commands that will
make it work assuming we're starting clean.  In fact, have us do a make
clean (if that's a good safety thing to do).  Assume we just untarred the
0.6.6 directory, did a make, then su and make install.  Then what?  Should
we be able to type a half dozens commands in and then be able to run
lircd -n in one session, ALT-F2 to another window and type irw and see it
echoing the codes back to us?

A little step-by-step would be EXTREMELY helpful!  For us and for all future
Creative users!

Thanks in advance!  I've spend just hours and hours on this and I think
others have too and have given up.  But, since some people have it going we
should all be able to with a little cookbook!  Thanks!

John


----- Original Message -----
From: "Karl Bongers" <
karl@turbobit.com>
To: <
Jeff_Mitchell@accessbusinessgroup.com>; "John" <johnmythtv@crombe.com>
Cc: <
lirc-list@lists.sourceforge.net>
Sent: Saturday, February 01, 2003 12:17 PM
Subject: Re: Lirc in Mandrake 9.0 -- configuration issues


Jeff:
There is a hw_creative.c driver under daemons that opens a stock
serial port(serial.o) at 2400 baud.  If you have lirc_serial.o loaded
this could cause lircd to fail "reseting tty".  So hw_creative.c needs
serial.o, not lirc_serial.o.
> lircd 0.6.6: accepted new client on /dev/lircd
> lircd 0.6.6: could not reset tty
> lircd 0.6.6: caught signal
> Terminated

John:
> crw-rw-rw-    1 root     root      61,   0 Jan 15 05:08 /dev/lirc
This should probably be a symbolic link to /dev/ttyS0, which would
point things at the serial.o driver.  I'm not positive on this, you
may just want to do another make install, this should set
it to what it should be.
> srw-rw-rw-    1 root     root            0 Jan 31 01:16 /dev/lircd=
I believe the = sign may be an indicator that it is a named UNIX
type socket channel.  Kinda like TCP/127.0.0.1, but without
the TCP.  Thats what lircd specifies as the channel type in socket()
creation to talk with irw and friends.

Oh, and irrecord would not apply to a hw_creative.c since it is
not a "learning remote"(lirc_serial.o).  You need to find and
use a pre-made creative lircd.conf file.

Hope I haven't steered you wrong.

Karl.


On Fri, Jan 31, 2003 at 12:08:57PM -0500,
Jeff_Mitchell@accessbusinessgroup.com wrote:
> All-
>
> Last night, I got a Creative IR reciever (with a little credit-card type
> remote), and went about installing LIRC from source on my Mandrake 9.0
> system.  I posted this same message to the mythtv list (guess what I'd
like
> to control with LIRC) as a "me, too" to another post, but figured it was
> more appropriate to post here when looking for answers.
>
> --snip--
>
> Amazingly, my Creative IR Reciever just came via UPS last night.  I'm
> running Mandrake 9.0, and opted to install from source.  I was getting the
> exact same behavior as the original post (the daemon crapping out because
> it couldn't open /dev/lirc), and I went through all sorts of machinations
> last night to get to the state I'm at now (I *think* I'm closer, but still
> not working.)
>
> I compiled and loaded the lirc_serial module (The setup script says it's
> not necessary, but I read about someone else needing it in one of the hits
> that Google turned up), and went through a few cycles of installing from
> source, uninstalling from source, installing the Mandrake-supplied
package,
> and inunstalling said rpm.
>
> Currently, here's my behavior:
>
> [root@localhost root]# cd /dev/
> [root@localhost dev]# ls -Al l*
> crw-rw-rw-    1 root     root      61,   0 Jan 31 00:09 lirc
> srw-rw-rw-    1 root     root            0 Jan 31 00:33 lircd=
> prw-r--r--    1 root     root            0 Jan 31 00:10 lircm|
> srw-rw-rw-    1 root     root            0 Jan 31 00:09 log=
> [root@localhost dev]# lircd -n
> lircd 0.6.6: lircd(creative) ready
> lircd 0.6.6: accepted new client on /dev/lircd
> lircd 0.6.6: could not reset tty
> lircd 0.6.6: caught signal
> Terminated
> [root@localhost dev]#
>
> It should be noted that after the line "lircd 0.6.6: lircd(creative)
> ready", there's a wait until I run irw from another terminal.  Also, the
> command lircd -n is the same as lircd -n -d /dev/lirc.  I've tried it,
> feeding /dev/lirc/0, /dev/lircd, and /dev/lircd/0, and all of those die,
> yelling about those devices not existing.
>
> --snip--
>
> Any [suggestions | questions | pointers to obvious places in the docs
where
> this is mentioned but I somehow missed last night] would be greatly
> appreciated.
>
> -Jeff
>
>
>
> -------------------------------------------------------
> This SF.NET email is sponsored by:
> SourceForge Enterprise Edition + IBM + LinuxWorld = Something 2 See!
>
http://www.vasoftware.com



-------------------------------------------------------
This SF.NET email is sponsored by:
SourceForge Enterprise Edition + IBM + LinuxWorld =omething 2 See!
http://www.vasoftware.com