Ok, so I bought this great little IR receiver that is supposed to do everything, including clean the bathroom, right? Well, only if I can get it setup in the first place!

 

I have been keeping track of my most recent attempt at getting this working (my first several attempts included using RPM installation methods, until I realized that I had to change source etc in order to get this to work). My notes to this point are found here: http://www.mitopia.net/index.php/Ira-3 (note that at this point there is a disclaimer at the top of the page saying I haven’t yet gotten it working. If you find this message in the archives looking for help, and the disclaimer is gone, that means that the directions are what finally worked for me!).

 

Anyways, so as the page shows, I have found that I need to use the Ira-3 as if it’s an irman with a few changes. I have made those changes, but still no luck. I have also tried libirman versions 0.4.2, 0.4.3, and 0.4.4 all with the source changes I have listed in my page. My problem though, is that when I test it with the test_io script that is made when you compile libirman I can’t get a valid response, and I think that is the root cause of my current problem. Here is what I get:

 

[root@mythfront libirman-0.4.4]# ./test_io /dev/ttyS1

IR

!!error reading handshake (Connection timed out)

[root@mythfront libirman-0.4.4]# ./test_io /dev/ttyS1

IR

OR!

 

My understanding is that it’s supposed to send “IR” and then receives “OK” from the Ira-3, but as you can see, the first time here I started to receive something, and then it timed out. The second time I received a complete response, but it’s definitely not “OK”.

 

I have done a lot of searching etc, and found someone named Mike (http://www.mythtv.org/pipermail/mythtv-users/2005-August/100322.html) that said he got his working without timeouts after he edited the libirman source to add a stop bit. Well, I have no idea how to do that, and he doesn’t list specifically he added to which file, etc.

 

So, has anyone ever ran into anything like this? Is it possible that I have a defective Ira-3 to begin with? I’m not thinking so, as the windows-based diagnostics say it’s working fine. I am running it on comm2 right now, but I was running it on comm1 initially and had simiar problems (I changed it over to comm2 before I knew that I had to use it as an irman).

 

Can anyone help? Thanks!

 

Mito