Unable to make Wacom Cintiq 13HD work on Fedora 18

2013-05-27
2013-06-28
  • Hi!

    First of all, I tried to mail the mailing list twice but I think it stripped half my mails both times so sorry for spaming my issue here as well!

    I have been trying my best the last two days to figure out how to make Wacom Cintiq 13HD to work on Fedora 18 since both the hardware and drivers are still pretty new. This is what I have been doing so far:

    • Kernel (including selinux-policies) has been updated to 3.9.2
    • Updated the libwacom.x86_64 package to the latest version (0.7.1)
    • Since Fedora 18 only provides 0.16 of the xf86-input-wacom (called xorg-x11-drv-wacom.x86_64 in Fedora), I built the currently latest version 0.21 using the descriptions on the wiki. And as far as I can tell, when switching back to my Intuos 3 the drivers at least works there.
    • Running xsetwacom list does not return anything when the Wacom Cintiq is plugged.
    • On the wiki, I followed the suggestion to see if it's listed in /proc/bus/input/devices. It appeared not to be shown there.
    • However, when checking the /var/log/messages I get this that seems to loop:

    kernel: [  548.886024] usb 1-2: new high-speed USB device number 17 using ehci-pci
    kernel: [  549.000706] usb 1-2: New USB device found, idVendor=056a, idProduct=0305
    kernel: [  549.000712] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    kernel: [  549.000716] usb 1-2: Product: Wacom Cintiq 13HD USB Hub
    kernel: [  549.000718] usb 1-2: Manufacturer: Wacom Co., Ltd.
    kernel: [  549.000992] hub 1-2:1.0: USB hub found
    kernel: [  549.001080] hub 1-2:1.0: 3 ports detected
    kernel: [  549.274084] usb 1-2.3: new full-speed USB device number 18 using ehci-pci
    kernel: [  549.360825] usb 1-2.3: New USB device found, idVendor=10c4, idProduct=ea60
    kernel: [  549.360829] usb 1-2.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    kernel: [  549.360832] usb 1-2.3: Product: CP2102 USB to UART Bridge Controller
    kernel: [  549.360835] usb 1-2.3: Manufacturer: Silicon Labs
    kernel: [  549.360838] usb 1-2.3: SerialNumber: 0001
    kernel: [  549.361735] cp210x 1-2.3:1.0: cp210x converter detected
    kernel: [  549.435075] usb 1-2.3: reset full-speed USB device number 18 using ehci-pci
    kernel: [  549.521222] usb 1-2.3: cp210x converter now attached to ttyUSB0
    kernel: [  549.698072] usb 1-2.1: new full-speed USB device number 19 using ehci-pci
    kernel: [  549.785697] usb 1-2.1: New USB device found, idVendor=056a, idProduct=0304
    kernel: [  549.785701] usb 1-2.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    kernel: [  549.785704] usb 1-2.1: Product: Wacom Cintiq 13HD
    kernel: [  549.785707] usb 1-2.1: Manufacturer: Wacom Co.,Ltd.
    mtp-probe: checking bus 1, device 18: "/sys/devices/pci0000:00/0000:00:1d.7/usb1/1-2/1-2.3"
    mtp-probe: checking bus 1, device 19: "/sys/devices/pci0000:00/0000:00:1d.7/usb1/1-2/1-2.1"
    mtp-probe: bus: 1, device: 18 was not an MTP device
    mtp-probe: bus: 1, device: 19 was not an MTP device
    dbus-daemon[592]: modem-manager[712]: <info>  (ttyUSB0) opening serial port...
    modem-manager[712]: <info>  (ttyUSB0) opening serial port...
    dbus-daemon[592]: modem-manager[712]: <info>  (ttyUSB0) closing serial port...
    modem-manager[712]: <info>  (ttyUSB0) closing serial port...
    modem-manager[712]: <info>  (ttyUSB0) serial port closed
    modem-manager[712]: <info>  (ttyUSB0) opening serial port...
    dbus-daemon[592]: modem-manager[712]: <info>  (ttyUSB0) serial port closed
    dbus-daemon[592]: modem-manager[712]: <info>  (ttyUSB0) opening serial port...
    dbus-daemon[592]: modem-manager[712]: <info>  (ttyUSB0) closing serial port...
    modem-manager[712]: <info>  (ttyUSB0) closing serial port...
    modem-manager[712]: <info>  (ttyUSB0) serial port closed
    modem-manager[712]: <info>  (ttyUSB0) opening serial port...
    dbus-daemon[592]: modem-manager[712]: <info>  (ttyUSB0) serial port closed
    dbus-daemon[592]: modem-manager[712]: <info>  (ttyUSB0) opening serial port...
    dbus-daemon[592]: modem-manager[712]: <info>  (ttyUSB0) closing serial port...
    modem-manager[712]: <info>  (ttyUSB0) closing serial port...
    modem-manager[712]: <info>  (ttyUSB0) serial port closed
    modem-manager[712]: <info>  (ttyUSB0) opening serial port...
    dbus-daemon[592]: modem-manager[712]: <info>  (ttyUSB0) serial port closed
    dbus-daemon[592]: modem-manager[712]: <info>  (ttyUSB0) opening serial port...
    dbus-daemon[592]: modem-manager[712]: <info>  (ttyUSB0) closing serial port...
    modem-manager[712]: <info>  (ttyUSB0) closing serial port...
    dbus-daemon[592]: modem-manager[712]: <info>  (ttyUSB0) serial port closed
    modem-manager[712]: <info>  (ttyUSB0) serial port closed
    kernel: [  595.003753] usb 1-2: USB disconnect, device number 17
    kernel: [  595.003760] usb 1-2.1: USB disconnect, device number 19
    kernel: [  595.003989] usb 1-2.3: USB disconnect, device number 18
    kernel: [  595.004179] cp210x ttyUSB0: cp210x converter now disconnected from ttyUSB0
    kernel: [  595.004201] cp210x 1-2.3:1.0: device disconnected
    kernel: [  595.239023] usb 1-2: new high-speed USB device number 20 using ehci-pci
    kernel: [  595.353710] usb 1-2: New USB device found, idVendor=056a, idProduct=0305
    kernel: [  595.353714] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    kernel: [  595.353717] usb 1-2: Product: Wacom Cintiq 13HD USB Hub
    kernel: [  595.353720] usb 1-2: Manufacturer: Wacom Co., Ltd.
    kernel: [  595.354141] hub 1-2:1.0: USB hub found
    kernel: [  595.354198] hub 1-2:1.0: 3 ports detected
    kernel: [  595.627087] usb 1-2.3: new full-speed USB device number 21 using ehci-pci
    kernel: [  595.711956] usb 1-2: clear tt 3 (0000) error -71
    kernel: [  595.915830] usb 1-2: clear tt 3 (0000) error -71
    kernel: [  596.112016] usb 1-2.3: device not accepting address 21, error -71
    kernel: [  596.115955] hub 1-2:1.0: cannot disable port 3 (err = -71)
    kernel: [  596.120203] hub 1-2:1.0: cannot reset port 3 (err = -71)
    kernel: [  596.124453] hub 1-2:1.0: cannot reset port 3 (err = -71)
    kernel: [  596.128702] hub 1-2:1.0: cannot reset port 3 (err = -71)
    kernel: [  596.132827] hub 1-2:1.0: cannot reset port 3 (err = -71)
    kernel: [  596.137077] hub 1-2:1.0: cannot reset port 3 (err = -71)
    kernel: [  596.137080] hub 1-2:1.0: Cannot enable port 3.  Maybe the USB cable is bad?
    kernel: [  596.141327] hub 1-2:1.0: cannot disable port 3 (err = -71)
    kernel: [  596.145576] hub 1-2:1.0: cannot reset port 3 (err = -71)
    kernel: [  596.149701] hub 1-2:1.0: cannot reset port 3 (err = -71)
    kernel: [  596.153952] hub 1-2:1.0: cannot reset port 3 (err = -71)
    kernel: [  596.158201] hub 1-2:1.0: cannot reset port 3 (err = -71)
    kernel: [  596.162452] hub 1-2:1.0: cannot reset port 3 (err = -71)
    kernel: [  596.162456] hub 1-2:1.0: Cannot enable port 3.  Maybe the USB cable is bad?
    kernel: [  596.166576] hub 1-2:1.0: cannot disable port 3 (err = -71)
    kernel: [  596.170826] hub 1-2:1.0: cannot reset port 3 (err = -71)
    kernel: [  596.175077] hub 1-2:1.0: cannot reset port 3 (err = -71)
    kernel: [  596.179326] hub 1-2:1.0: cannot reset port 3 (err = -71)
    kernel: [  596.183452] hub 1-2:1.0: cannot reset port 3 (err = -71)
    kernel: [  596.187701] hub 1-2:1.0: cannot reset port 3 (err = -71)
    kernel: [  596.187705] hub 1-2:1.0: Cannot enable port 3.  Maybe the USB cable is bad?
    kernel: [  596.191953] hub 1-2:1.0: cannot disable port 3 (err = -71)
    kernel: [  596.191959] hub 1-2:1.0: unable to enumerate USB device on port 3
    kernel: [  596.196201] hub 1-2:1.0: cannot disable port 3 (err = -71)
    kernel: [  596.196222] usb 1-2: USB disconnect, device number 20
    kernel: [  596.404020] usb 1-2: new high-speed USB device number 25 using ehci-pci
    kernel: [  596.518701] usb 1-2: New USB device found, idVendor=056a, idProduct=0305
    kernel: [  596.518705] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    kernel: [  596.518708] usb 1-2: Product: Wacom Cintiq 13HD USB Hub
    kernel: [  596.518711] usb 1-2: Manufacturer: Wacom Co., Ltd.
    kernel: [  596.519115] hub 1-2:1.0: USB hub found
    kernel: [  596.519189] hub 1-2:1.0: 3 ports detected
    kernel: [  596.792072] usb 1-2.3: new full-speed USB device number 26 using ehci-pci
    kernel: [  596.878821] usb 1-2.3: New USB device found, idVendor=10c4, idProduct=ea60
    kernel: [  596.878825] usb 1-2.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    kernel: [  596.878829] usb 1-2.3: Product: CP2102 USB to UART Bridge Controller
    kernel: [  596.878831] usb 1-2.3: Manufacturer: Silicon Labs
    kernel: [  596.878834] usb 1-2.3: SerialNumber: 0001
    kernel: [  596.879729] cp210x 1-2.3:1.0: cp210x converter detected
    kernel: [  596.953077] usb 1-2.3: reset full-speed USB device number 26 using ehci-pci
    kernel: [  597.039180] usb 1-2.3: cp210x converter now attached to ttyUSB0
    kernel: [  597.216071] usb 1-2.1: new full-speed USB device number 27 using ehci-pci
    kernel: [  597.303695] usb 1-2.1: New USB device found, idVendor=056a, idProduct=0304
    kernel: [  597.303699] usb 1-2.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    kernel: [  597.303702] usb 1-2.1: Product: Wacom Cintiq 13HD
    kernel: [  597.303705] usb 1-2.1: Manufacturer: Wacom Co.,Ltd.
    mtp-probe: checking bus 1, device 26: "/sys/devices/pci0000:00/0000:00:1d.7/usb1/1-2/1-2.3"
    mtp-probe: checking bus 1, device 27: "/sys/devices/pci0000:00/0000:00:1d.7/usb1/1-2/1-2.1"
    mtp-probe: bus: 1, device: 26 was not an MTP device
    mtp-probe: bus: 1, device: 27 was not an MTP device
    dbus-daemon[592]: modem-manager[712]: <info>  (ttyUSB0) opening serial port...
    modem-manager[712]: <info>  (ttyUSB0) opening serial port...
    

    Anyone else getting the same problems? It looks like it finds the Wacom at least in the log above but something that happens afterwards stops it from working. What does it mean?

    Best regards,
    Andreas

     
    • Ping Cheng
      Ping Cheng
      2013-06-05

      You need to upgrade the kernel driver by build and install input-wacom as
      well.

      Ping

      On Mon, May 27, 2013 at 2:04 AM, Andreas Ekoutsidis
      daiboushi@users.sf.netwrote:

      Hi!

      First of all, I tried to mail the mailing list twice but I think it
      stripped half my mails both times so sorry for spaming my issue here as
      well!

      I have been trying my best the last two days to figure out how to make
      Wacom Cintiq 13HD to work on Fedora 18 since both the hardware and drivers
      are still pretty new. This is what I have been doing so far:

      • Kernel (including selinux-policies) has been updated to 3.9.2
      • Updated the libwacom.x86_64 package to the latest version (0.7.1)
      • Since Fedora 18 only provides 0.16 of the xf86-input-wacom (called
        xorg-x11-drv-wacom.x86_64 in Fedora), I built the currently latest version
        0.21 using the descriptions on the wiki. And as far as I can tell, when
        switching back to my Intuos 3 the drivers at least works there.
      • Running xsetwacom list does not return anything when the Wacom
        Cintiq is plugged.
      • On the wiki, I followed the suggestion to see if it's listed in
        /proc/bus/input/devices. It appeared not to be shown there.
      • However, when checking the /var/log/messages I get this that seems
        to loop:

      kernel: [ 548.886024] usb 1-2: new high-speed USB device number 17 using ehci-pcikernel: [ 549.000706] usb 1-2: New USB device found, idVendor=056a, idProduct=0305kernel: [ 549.000712] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0kernel: [ 549.000716] usb 1-2: Product: Wacom Cintiq 13HD USB Hubkernel: [ 549.000718] usb 1-2: Manufacturer: Wacom Co., Ltd.kernel: [ 549.000992] hub 1-2:1.0: USB hub foundkernel: [ 549.001080] hub 1-2:1.0: 3 ports detectedkernel: [ 549.274084] usb 1-2.3: new full-speed USB device number 18 using ehci-pcikernel: [ 549.360825] usb 1-2.3: New USB device found, idVendor=10c4, idProduct=ea60kernel: [ 549.360829] usb 1-2.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3kernel: [ 549.360832] usb 1-2.3: Product: CP2102 USB to UART Bridge Controllerkernel: [ 549.360835] usb 1-2.3: Manufacturer: Silicon Labskernel: [ 549.360838] usb 1-2.3: SerialNumber: 0001kernel: [ 549.361735] cp210x 1-2.3:1.0: cp210x converter detectedkernel: [ 549.435075] usb 1-2.3: reset full-speed USB device number 18 using ehci-pcikernel: [ 549.521222] usb 1-2.3: cp210x converter now attached to ttyUSB0kernel: [ 549.698072] usb 1-2.1: new full-speed USB device number 19 using ehci-pcikernel: [ 549.785697] usb 1-2.1: New USB device found, idVendor=056a, idProduct=0304kernel: [ 549.785701] usb 1-2.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0kernel: [ 549.785704] usb 1-2.1: Product: Wacom Cintiq 13HDkernel: [ 549.785707] usb 1-2.1: Manufacturer: Wacom Co.,Ltd.mtp-probe: checking bus 1, device 18: "/sys/devices/pci0000:00/0000:00:1d.7/usb1/1-2/1-2.3"mtp-probe: checking bus 1, device 19: "/sys/devices/pci0000:00/0000:00:1d.7/usb1/1-2/1-2.1"mtp-probe: bus: 1, device: 18 was not an MTP devicemtp-probe: bus: 1, device: 19 was not an MTP devicedbus-daemon[592]: modem-manager[712]: <info> (ttyUSB0) opening serial port...modem-manager[712]: <info> (ttyUSB0) opening serial port...dbus-daemon[592]: modem-manager[712]: <info> (ttyUSB0) closing serial port...modem-manager[712]: <info> (ttyUSB0) closing serial port...modem-manager[712]: <info> (ttyUSB0) serial port closedmodem-manager[712]: <info> (ttyUSB0) opening serial port...dbus-daemon[592]: modem-manager[712]: <info> (ttyUSB0) serial port closeddbus-daemon[592]: modem-manager[712]: <info> (ttyUSB0) opening serial port...dbus-daemon[592]: modem-manager[712]: <info> (ttyUSB0) closing serial port...modem-manager[712]: <info> (ttyUSB0) closing serial port...modem-manager[712]: <info> (ttyUSB0) serial port closedmodem-manager[712]: <info> (ttyUSB0) opening serial port...dbus-daemon[592]: modem-manager[712]: <info> (ttyUSB0) serial port closeddbus-daemon[592]: modem-manager[712]: <info> (ttyUSB0) opening serial port...dbus-daemon[592]: modem-manager[712]: <info> (ttyUSB0) closing serial port...modem-manager[712]: <info> (ttyUSB0) closing serial port...modem-manager[712]: <info> (ttyUSB0) serial port closedmodem-manager[712]: <info> (ttyUSB0) opening serial port...dbus-daemon[592]: modem-manager[712]: <info> (ttyUSB0) serial port closeddbus-daemon[592]: modem-manager[712]: <info> (ttyUSB0) opening serial port...dbus-daemon[592]: modem-manager[712]: <info> (ttyUSB0) closing serial port...modem-manager[712]: <info> (ttyUSB0) closing serial port...dbus-daemon[592]: modem-manager[712]: <info> (ttyUSB0) serial port closedmodem-manager[712]: <info> (ttyUSB0) serial port closedkernel: [ 595.003753] usb 1-2: USB disconnect, device number 17kernel: [ 595.003760] usb 1-2.1: USB disconnect, device number 19kernel: [ 595.003989] usb 1-2.3: USB disconnect, device number 18kernel: [ 595.004179] cp210x ttyUSB0: cp210x converter now disconnected from ttyUSB0kernel: [ 595.004201] cp210x 1-2.3:1.0: device disconnectedkernel: [ 595.239023] usb 1-2: new high-speed USB device number 20 using ehci-pcikernel: [ 595.353710] usb 1-2: New USB device found, idVendor=056a, idProduct=0305kernel: [ 595.353714] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0kernel: [ 595.353717] usb 1-2: Product: Wacom Cintiq 13HD USB Hubkernel: [ 595.353720] usb 1-2: Manufacturer: Wacom Co., Ltd.kernel: [ 595.354141] hub 1-2:1.0: USB hub foundkernel: [ 595.354198] hub 1-2:1.0: 3 ports detectedkernel: [ 595.627087] usb 1-2.3: new full-speed USB device number 21 using ehci-pcikernel: [ 595.711956] usb 1-2: clear tt 3 (0000) error -71kernel: [ 595.915830] usb 1-2: clear tt 3 (0000) error -71kernel: [ 596.112016] usb 1-2.3: device not accepting address 21, error -71kernel: [ 596.115955] hub 1-2:1.0: cannot disable port 3 (err = -71)kernel: [ 596.120203] hub 1-2:1.0: cannot reset port 3 (err = -71)kernel: [ 596.124453] hub 1-2:1.0: cannot reset port 3 (err = -71)kernel: [ 596.128702] hub 1-2:1.0: cannot reset port 3 (err = -71)kernel: [ 596.132827] hub 1-2:1.0: cannot reset port 3 (err = -71)kernel: [ 596.137077] hub 1-2:1.0: cannot reset port 3 (err = -71)kernel: [ 596.137080] hub 1-2:1.0: Cannot enable port 3. Maybe the USB cable is bad?kernel: [ 596.141327] hub 1-2:1.0: cannot disable port 3 (err = -71)kernel: [ 596.145576] hub 1-2:1.0: cannot reset port 3 (err = -71)kernel: [ 596.149701] hub 1-2:1.0: cannot reset port 3 (err = -71)kernel: [ 596.153952] hub 1-2:1.0: cannot reset port 3 (err = -71)kernel: [ 596.158201] hub 1-2:1.0: cannot reset port 3 (err = -71)kernel: [ 596.162452] hub 1-2:1.0: cannot reset port 3 (err = -71)kernel: [ 596.162456] hub 1-2:1.0: Cannot enable port 3. Maybe the USB cable is bad?kernel: [ 596.166576] hub 1-2:1.0: cannot disable port 3 (err = -71)kernel: [ 596.170826] hub 1-2:1.0: cannot reset port 3 (err = -71)kernel: [ 596.175077] hub 1-2:1.0: cannot reset port 3 (err = -71)kernel: [ 596.179326] hub 1-2:1.0: cannot reset port 3 (err = -71)kernel: [ 596.183452] hub 1-2:1.0: cannot reset port 3 (err = -71)kernel: [ 596.187701] hub 1-2:1.0: cannot reset port 3 (err = -71)kernel: [ 596.187705] hub 1-2:1.0: Cannot enable port 3. Maybe the USB cable is bad?kernel: [ 596.191953] hub 1-2:1.0: cannot disable port 3 (err = -71)kernel: [ 596.191959] hub 1-2:1.0: unable to enumerate USB device on port 3kernel: [ 596.196201] hub 1-2:1.0: cannot disable port 3 (err = -71)kernel: [ 596.196222] usb 1-2: USB disconnect, device number 20kernel: [ 596.404020] usb 1-2: new high-speed USB device number 25 using ehci-pcikernel: [ 596.518701] usb 1-2: New USB device found, idVendor=056a, idProduct=0305kernel: [ 596.518705] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0kernel: [ 596.518708] usb 1-2: Product: Wacom Cintiq 13HD USB Hubkernel: [ 596.518711] usb 1-2: Manufacturer: Wacom Co., Ltd.kernel: [ 596.519115] hub 1-2:1.0: USB hub foundkernel: [ 596.519189] hub 1-2:1.0: 3 ports detectedkernel: [ 596.792072] usb 1-2.3: new full-speed USB device number 26 using ehci-pcikernel: [ 596.878821] usb 1-2.3: New USB device found, idVendor=10c4, idProduct=ea60kernel: [ 596.878825] usb 1-2.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3kernel: [ 596.878829] usb 1-2.3: Product: CP2102 USB to UART Bridge Controllerkernel: [ 596.878831] usb 1-2.3: Manufacturer: Silicon Labskernel: [ 596.878834] usb 1-2.3: SerialNumber: 0001kernel: [ 596.879729] cp210x 1-2.3:1.0: cp210x converter detectedkernel: [ 596.953077] usb 1-2.3: reset full-speed USB device number 26 using ehci-pcikernel: [ 597.039180] usb 1-2.3: cp210x converter now attached to ttyUSB0kernel: [ 597.216071] usb 1-2.1: new full-speed USB device number 27 using ehci-pcikernel: [ 597.303695] usb 1-2.1: New USB device found, idVendor=056a, idProduct=0304kernel: [ 597.303699] usb 1-2.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0kernel: [ 597.303702] usb 1-2.1: Product: Wacom Cintiq 13HDkernel: [ 597.303705] usb 1-2.1: Manufacturer: Wacom Co.,Ltd.mtp-probe: checking bus 1, device 26: "/sys/devices/pci0000:00/0000:00:1d.7/usb1/1-2/1-2.3"mtp-probe: checking bus 1, device 27: "/sys/devices/pci0000:00/0000:00:1d.7/usb1/1-2/1-2.1"mtp-probe: bus: 1, device: 26 was not an MTP devicemtp-probe: bus: 1, device: 27 was not an MTP devicedbus-daemon[592]: modem-manager[712]: <info> (ttyUSB0) opening serial port...modem-manager[712]: <info> (ttyUSB0) opening serial port...

      Anyone else getting the same problems? It looks like it finds the Wacom at
      least in the log above but something that happens afterwards stops it from
      working. What does it mean?

      Best regards,
      Andreas


      Unable to make Wacom Cintiq 13HD work on Fedora 18https://sourceforge.net/p/linuxwacom/discussion/236871/thread/e654308b/?limit=50#da4e

      Sent from sourceforge.net because you indicated interest in
      https://sourceforge.net/p/linuxwacom/discussion/236871/

      To unsubscribe from further messages, please visit
      https://sourceforge.net/auth/subscriptions/

       
      • Thank you for clearing that out for me Ping! It works now! But I did use the existing wacom.ko and wacom_w8001.ko for kernel "3.7" as I did not find build instructions to rebuild those for my kernel version. Is this OK?