Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Wacom Intuos5 Touch S

Renate
2012-03-30
2013-04-05
  • Renate
    Renate
    2012-03-30

    are there planned drivers for intuos 5 too. Until now, lusb recognizes the device in archlinux 3.2.13-1-ARCH. But there is made no device.

     
  • Renate
    Renate
    2012-03-31

    I have tried with xf86-input-wacom. ABS of Archlinux. I unpacked xf86-input-wacom-0.14.0.tar.bz2, changed the files and packed again for makepkg. Pcaman did the upgrade, but that alone ist not enough.

    The first patch, I have no wacom_wac.c and wacom_wac.h. In Archlinux I can wait for the 3.4 kernel, in Ubuntu Precise … but I am glad, that I can use the tablet pen in Linux in future.

    Thanks.

     
  • Renate
    Renate
    2012-04-26

    I have downloaded input-wacom at git browse. There I found the files for the first point. ./autogen.sh and I get a wacom.ko to copy. I have to do at every kernel update and then the pen stift works.

     
  • Favux
    Favux
    2012-04-26

    Right you need a new wacom.ko that supports the Intuos5 because each new kernel has a new modules directory that has the old non-working wacom.ko.

    You could set up a dkms implementation of the input-wacom-0.13.0 wacom.ko and then it would automatically add the wacom.ko that supports your Intuos5 with each kernel update.

    Have you talked to Andrzej Giniewicz <gginiu@gmail.com> about this?  He is the maintainer of the Arch wacom-drivers 1-1 PKGBUILD:  https://aur.archlinux.org/packages.php?ID=48555  He's used input-wacom for its wacom.ko in the past.  He could probably get Intuos5 support into Arch if you asked him.