quota and automount

Help
2007-02-20
2013-03-26
  • Pablo Roldan
    Pablo Roldan
    2007-02-20

    Hi,

    Newbee question:

    I'm trying to get quota to work over NFS in a beowulf cluster with debian.
    Each user has its home dir in a different node, and they are automounted
    on the rest of the nodes using autofs.

    I've been looking for help on configuring the quota system for this particular
    setup, but I couldn't find any help so far. Any hint? Thanks a lot,
    /P

     
    • Jan Kara
      Jan Kara
      2007-02-21

      And what problem do you exactly have? Because each of your nodes acts as an NFS server, you have to run rpc.rquota on each of the nodes. Apart from that I don't see any problem you might encounter.

       
    • Pablo Roldan
      Pablo Roldan
      2007-02-28

      Yeah, sorry, I wasn't being very specific.

      Say a home dir is in node1:/homes/user, and it is mounted in a second node, as in node2:/home/user.

      Do I need to edit /etc/fstab in node1 and activate usrquota for partition /homes? Do I need to edit fstab in node2?

      Sould I do quotacheck/quotaon on node1 or node2, or both?

      Do I need to modify any other NFS-related file like exports? Do I need to modify any automount-related file like /etc/auto.master, /etc/auto.home?

      Thanks for the help,
      /P

       
    • Jan Kara
      Jan Kara
      2007-03-12

      Firstly, you don't have to edit anything automount related or exports file. quotacheck(8) has to be run only on servers - i.e. on each node that contains a physical disk with the exported filesystem - in your example node1. You have to edit /etc/fstab on node1 to enable quotas on /homes and rpc.quotad should be running on node1.