Quota daemon

  • darryl penny
    darryl penny


    can anyone tell me why (or point me to info) quotad will not start?
    I have quota running no sweat, am able to edit and view quotas, but quotad will not start. Maybe I'm missing something.


    • quotad??
      Maybe you are talking about rquotad.
      This is used to display or set user quotas for remote file systems (using nfs).
      If this is what you are searching for, try
      man rquotad
      or try:
      rpc.rquotad --help
      (rpc.rquotad is the daemon file and it belongs to quota package)

      I don't have any experience with that, but I hope this will help you.


    • darryl penny
      darryl penny

      Thanks, Manuel. I had a look at man rquotad - for remote quotas. It's supposed to start at boot and mine doesn't. I wonder if that only happens if NFS is configured? Oh well, I not using NFS at the moment.

      What I'm concerned with is why SuSE 8.2 allowed users to go way over hard limits in the first place and I imagined that quotd not starting had something to do with it.

      • >It's supposed to start at boot and mine doesn't.

        No. It doesn't start at boot time by default. Rquotad is only used if you want to control quotas in a remote filsystem (i.e. a remote computer).
        So, I think nfs must be enabled in the other computer and then start rquoatd with inetd.
        I don't consider this a good idea...

        >What I'm concerned with is why SuSE 8.2 allowed users to go way over hard limits...

        You have to find another explanation.
        Remember that: There are some applications that don't work with quotas, or must be enabled to use quotas (ex: mail servers, ftp servers...). It depends on the application itself.

        • darryl penny
          darryl penny

          OK, I'll forget quotad for now. Thanks.

          As far as going way over quota is concerned, my W98 workstations are basically using a microsoft package and web-based e-mail (Open Webmail).
          They save to the SuSE logon server where their home-drives are, so I want to apply quotas there.

          • First you have to be sure your quotas were mounted when booting.
            Check your /etc/fstab.
            It must have the filesystem (you want to apply quotas) with some arguments like this example:

            /dev/hda2   /home    ext3  defaults,usrquota, grpquota  1  1

            If this is not setup, they don't work at all.

            If this is ok, and quotas are working you must read this link from openwebmail, and find USER QUOTA, where they explain how to enable them with this software:

            I don't have experince with openwebmail, but the text seems to be very explanatory.

            If you still have problems seting up quotas, i'll send you a small 'how-to' I did for myself.


    • darryl penny
      darryl penny

      Thanks for the pointers, Manuel.
      I'll have a look at the readme. The files causing useage to exceed quotas are mostly not mail files, however.
      I'm beginning to wonder if quotas were not off for awhile at some stage. To make sure, I've enabled a daily cron job to stop quotas, do a quotacheck them a repquota -a then restart quotas (and mail me the result of requotas). Works like a charm.

      BTW my fstab is correct and quotas are loaded at boot-time (and stay running)