Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#35 Compiling / Installing on RH 9 Uniprocessor Kernel

open
nobody
5
2006-11-22
2006-11-22
Lee B
No

Hi,

I'm trying to install and compile 3.6.3 onto Red Hat 9 (Shrike) running on the Uniprocessor kernel.

The make and make install phase seems to go ok apart from warnings that the compilation will be against kernel 2.4.20-8 and I am running 2.4.20-8custom. Interestingly this isn't a custom kernel but a standard one of the Red Hat CD.

When I then try the command "service start iscsi" it fails and in the /var/log/iscsi.log I get the following:

[root@server-08 linux-iscsi-3.6.3]# more /var/log/iscsi.log

/lib/modules/2.4.20-8/misc/iscsi_sfnet.o: kernel-module version mismatch
/lib/modules/2.4.20-8/misc/iscsi_sfnet.o was compiled for kernel version
2.4.20-8smp
while this kernel is version 2.4.20-8.
/lib/modules/2.4.20-8/misc/iscsi_sfnet.o: insmod /lib/modules/2.4.20-8/misc/iscs
i_sfnet.o failed
/lib/modules/2.4.20-8/misc/iscsi_sfnet.o: insmod iscsi_sfnet failed

I have tried setting the KERNEL_CONFIG line as follows in the Makefile and it's not helped:

KERNEL_CONFIG:=/boot/config-2.4.20-8

Anyone any ideas on this please?

Thanks a lot in advance,

Lee.

Discussion