Do not be surprised at the lack of response.  You have provided very little information on your problem, and have not done your homework.
 
I would strongly suggest purchasing a copy of Linux Kernel Development, 2nd edition, by Robert Love.  It's an excellent book for giving an introduction to many aspects of the kernel.  In particular, pages 16 and 17 provide answers to your questions, which many of the other readers of these lists have already answered.  A quick read through that book will save you time when you're confronted with these types of problems.
 
Shane

 
On 10/25/07, kaka <share.kt@gmail.com> wrote:
Hi All,
 
Thanks for the overhelming responses.
I was able to remove the problem of Unknown symbols by linking the proper libraries. Now the problem got reduced to the following messages.
 
# insmod brcmstfb.ko
brcmstfb: Unknown symbol printf
brcmstfb: Unknown symbol malloc
brcmstfb: Unknown symbol free
insmod: cannot insert `brcmstfb.ko': Unknown symbol in module (2): No such file or directory
#
 
for the above problem i had tried to link "libgcc.a " but those symbols are also undefined in it also.
RECAP:
While running  the cross compiled directFB example on MIPS chip,*
We tried to install the framebuffer driver(command given above) after creating the node fb0.
APPROACH:
Actually the code of frambuffer driver consists of usual kernel framebuffer code and properitiary graphics lib code.
The properitiary graphics lib code is using malloc,print and free from <stdlib.h> and that is why those symbols are coming undefined.
 
Could anybody help in this regard?
Thanks in advance.
 
kaka
 


---------- Forwarded message ----------
From: kaka < share.kt@gmail.com>
Date: Oct 12, 2007 6:33 PM
Subject: Error opening framebuffer device/Unknown symbol register_framebuffer
To: directfb-users@directfb.org, directfb-dev@directfb.org .

 
Hi All,
While running  the cross compiled directFB example on MIPS chip,





We tried to install the framebuffer driver(command given at the bottom) and we have already created the node fb0.
We are getting the following error, 




Can anybody help in this regard ?
Thanks in Advance.
# ../../cross_directfb/simple_mips
                                                                                                                             
     =======================|  DirectFB 1.0.0  |=======================
          (c) 2001-2007  The DirectFB Organization (directfb.org)
          (c) 2000-2004  Convergence (integrated media) GmbH
        ------------------------------------------------------------
                                                                                                                             
(*) DirectFB/Core: Single Application Core. (2007-10-05 14:17)
(!) Direct/Util: opening '/dev/fb0' failed
    --> No such device or address
(!) DirectFB/FBDev: Error opening framebuffer device!
(!) DirectFB/FBDev: Use 'fbdev' option or set FRAMEBUFFER environment variable.
(!) DirectFB/Core: Could not initialize 'system' core!
    --> Initialization error!
simple.c <96>:
        (#) DirectFBError [DirectFBCreate (&dfb)]: Initialization error!
#
While running the following command in MIPS chip, we are getting the following error.
# insmod brcmstfb.ko
brcmstfb: Unknown symbol unregister_framebuffer
brcmstfb: Unknown symbol printf
brcmstfb: Unknown symbol malloc
brcmstfb: Unknown symbol fb_find_mode
brcmstfb: Unknown symbol fb_dealloc_cmap
brcmstfb: Unknown symbol fb_alloc_cmap
brcmstfb: Unknown symbol framebuffer_release
brcmstfb: Unknown symbol free
insmod: cannot insert `brcmstfb.ko': Unknown symbol in module (2): No such file or directory
#
#
 



--
Thanks & Regards,
kaka

--
Thanks & Regards,
kaka