Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#4 linux-abi-2.6.6

open
nobody
None
5
2004-06-07
2004-06-07
Anonymous
No

Linux is GPLed code.
LinuxABI is a patch against Linux.
linux-abi-2.6.6 is a slightlly modified version of
LinuxABI matching Linux kernel 2.6.6 from kernel.org
and mirrors.
the attached code is assumed to be GPLed code as well.

this code should generally work for misc minor and
major aims.
know limititations:
- exe-symlink in proc file system is not functional.
- tons of yet undiscovered bugs

signature

<tycoon>

Discussion

  • Logged In: NO

    I would like to thank whomever it is who is maintaining this important piece of code. It is critical to those of us who have migrated customers from Open Server to Linux. Legacy apps are an ugly, but unavoidable fact of life.

    Steve Bergman
    steve@rueb.com

     
  • Fred Wenzel
    Fred Wenzel
    2004-06-22

    Logged In: YES
    user_id=182121

    For today, you're my hero ;)

    You did what I wanted for some months now: port the abi patch
    to 2.6 - thanks a lot.

    I will gladly port your patch on to the most recent kernel
    versions.

    As Steve already stated: Legacy apps are ugly - but
    inevitable in some cases. Let's keep this work up :)

     
  • Logged In: NO

    Can this not find its way into the mainstream kernel?

     
  • Fred Wenzel
    Fred Wenzel
    2004-07-21

    Logged In: YES
    user_id=182121

    no, most unfortunately, it can't. Linus Torvalds was once
    asked to do so - and he answered that he doesn't want to
    support closed-source software that's not helping the
    community by including such a piece of code in the main
    kernel stream.

    I can understand that.

    Anyway, who needs this will surely be able to patch it into
    a kernel source distribution as all of us do ;)

    Head up, it could be worse ;)

     
  • lucap45
    lucap45
    2004-09-06

    Logged In: YES
    user_id=1114567

    hi, i'm not so much expert in linux, but i'm using since a
    couple of years.
    i've tryed installed on fedora 2 the kernel 2.6.6 with the
    linux-abi-2.6.6 patch
    i've rebuild kernel, i've done modprobe for abi-ibcs and
    binfmt_coff without any problem, but when i run my
    openserver application i receive "segmentation fault"
    somebody can help me?