Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

exporting to postscript

2009-02-16
2012-12-12
  • Andrew Collier
    Andrew Collier
    2009-02-16

    hi,

    i have just installed linsmith and played around with generating charts in the gui. this works really well. however, when i try to export my chart to postscript a whole string of errors appears on the terminal:

    Could not get font: Helvetica
    Could not get font: Helvetica
    Could not get font: Helvetica
    Could not get font: Helvetica
    Could not get font: Helvetica
    Could not get font: Helvetica
    Could not get font: Helvetica
    Could not get font: Helvetica
    Could not get font: Helvetica
    Could not get font: Helvetica
    Could not get font: Helvetica
    Could not get font: Helvetica
    Could not get font: Helvetica
    Could not get font: Helvetica
    Could not get font: Helvetica

    and when i open the resulting postscript file the text is huge and ugly. this is obviously some sort of font problem. i suspect that the font that linsmith is trying to use is not available on my computer. i have tried changing the fonts used in the preferences but this does not appear to have any effect on the postscript output.

    if anybody has an idea of how to fix this problem, i would really appreciate the help.

    best regards,
    andrew.

     
    • John Coppens
      John Coppens
      2009-02-16

      Hello Andrew.

      Thanks for reporting the issue. This is the first time I had a report on a problem with the Postscript generation, so I'll need a little more information.

      Which Linux distribution do you installed (name and version, please)?

      There have been some changes in font selection over the last years which may cause some incompatibilities. In some distros Helvetica doesn't actually exist, but frequently there are equivalence tables which translate one into the other.

      John

       
    • John Coppens
      John Coppens
      2009-02-20

      On Fri, 20 Feb 2009 02:05:24 -0800 (PST)
      Andrew Collier <abcollier@yahoo.com> wrote:

      > thanks. i fiddled around with my system settings and eventually got it
      > to work.
      >
      > thanks a lot!

      You're welcome.
      John