#4 How do I update?

open
nobody
5
2012-05-08
2012-05-08
Anonymous
No

Hi,

I'm trying out LilypondTool, the version which is downloaded within jEdit is 2.12, I've downloaded 2.14.20111117 and copied the jars to the .jedit jars folder, and copied lilypond.xml to the modes folder (replacing the orginal, which on windows is in the Program Files jEdit folder, not in the user .jEdit folder where the jars are.

jEdit Plugin Manager now says I have 2.14.20111117 running, however..

1) The interface looks no different to before that I notice, and notably different to the flash demos on your site.
2) I get no automatic preview, although that is ticked in the options, if I change something in the source, the pdf doesn't change, even if I save.
3) There is no LilyjHelp.jar file in the download, rather a zip file containing pngs and xml files and no instructions what to do with it.

Discussion


  • Anonymous
    2012-05-08

    The demos are for a very old version.
    Make sure that the lilypond command is correctly set in Plugin Options > LilyPondTool.
    You can attach the output from Troubleshooting > Activity log.
    But surely it is time for me to include the 2.14 version in the jEdit plugin repository. I hope I will have time for that some time.

     

  • Anonymous
    2012-05-08

    Thanks for the speedy response.

    It seems it is compiling on a save now, with the pdf preview updating, however...

    1) I get nothing in the error list window, even with intionaly bad input
    2) There is no update on changes without save, I'm not sure if this should happen or not (I ticked parse on keystroke)
    3) No automatic insertion of bars as shown in your flash demo
    4) The following file
    \version "2.15.38"

    % Created on Tue May 08 05:08:35 BST 2012
    {c8 d e4 g

    Gives the following log

    12:43:55 [AWT-EventQueue-0] [notice] LilyToolPlugin: running command %lilypond %args "C:\Users\Public\Desktop\test2.ly"
    12:43:55 [AWT-EventQueue-0] [debug] EditBus: VFSUpdate[path=C:\Users\Public\Desktop,source=null]
    12:43:55 [AWT-EventQueue-0] [debug] EditBus: VFSUpdate[path=C:\Users\Public\Desktop\#test2.ly#save#,source=null]
    12:43:55 [AWT-EventQueue-0] [debug] EditBus: VFSUpdate[path=C:\Users\Public\Desktop\test2.ly,source=null]
    12:43:57 [output] [error] output: java.lang.ArrayIndexOutOfBoundsException: Array index out of range: 110
    12:43:57 [output] [error] output: at org.gjt.sp.jedit.buffer.JEditBuffer.getLineText(JEditBuffer.java:467)
    12:43:57 [output] [error] output: at lilytool.console.ConsoleProcess$StreamThread.foundProblem(ConsoleProcess.java:192)
    12:43:57 [output] [error] output: at lilytool.console.ConsoleProcess$StreamThread.run(ConsoleProcess.java:157)

    It might help if I could install the help files by the way, but I don't know how to since it seems either the format has changed or the ones in the download need to be compiled in some way?