First, I want to thank everybody who is trying to help a noob such as myself with this problem.  You guys are great.

To answer Brett's question, JEdit is 4.3.2.  LilyPondTool is 2.12.894.

Below, I copy a note I sent off-list to another potential savior explaining the latest problem.  If anybody on the list can help me with this and help me get the freaking program going, I would be eternally grateful.

James Bailey said he uses the command line.  James, I assume you can do that in Snow Leopard?  The only reason I've been trying to run LilyPond with JEdit and LilyPondTool is that a friend of mine uses that combination (albeit from a Vista installation), and he loves the way he gets instant feedback on what his code actually looks like.  I'd like to do that if I can.  Do you find that you can get a visual confirmation of what you're doing via the command line frequently enough for what you need?

At any rate, here is the note describing my most recent trouble:

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +

QUOTE:

Well, I think my original problems were due to the fact that a previous install had forced Lilypond.app to rename itself to LilyPond 2.app.

I nuked the older version and reinstalled.

However, now I have a DIFFERENT problem.

I try to get LilyPond to process code from within JEdit and LilyPondTool, and I get this error:

Error running external command
See the activity log about the problem
Cannot run program "/Applications/LilyPond.app/Contents/Resources/bin/lilypond" (in directory "/Applications/LilyPond.app/Contents/Resources/bin"): error=13, Permission denied

I don't get this.  I'm the only user of my MacBook, not counting a test account with almost no privileges I created.

If the main user doesn't have permission to use the program, what the hell is going on?

If you have any ideas, I'd appreciate hearing them.

Seth


On Thu, Sep 9, 2010 at 4:48 AM, Brett Duncan <bdd1967@bigpond.net.au> wrote:
 On 9/09/10 4:37 AM, Seth Williamson wrote:
Is there anybody on this list who uses LilyPondTool on a MacBook?

Please get back with me -- feel free to reply offlist.


Seth Williamson

Hi Seth,

I've been using jEdit and LilyPondTool on a Mac for some time, so maybe I can help you get things sorted out.

What versions of jEdit and LPT are you using? (I have 4.3pre14 and 2.10.5 respectively.)

In my current setup, my path for the Lilypond binary is simply /Applications and that seems to work fine. That hasn't always been the case with the various versions of LPT, but it's worth a try.

Brett