Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#71 convert-ly no longer works from menu/toolbar

open
nobody
None
5
2011-11-21
2011-11-21
Nick Payne
No

I downloaded and unzipped lilypondtool-2.14.20111117.zip over the top of the previous version of Lilypondtool in my .jedit folder. The one thing that doesn't work for me with this preview version is to run convert-ly from the toolbar or menu. When I do that, nothing happens (no console window appears) and the version number in the ly file doesn't update. The plugin options (path to lilypond binaries, convert-ly command, etc) are correctly set and the same as they were in the previous version, where this worked. convert-ly runs from the command line without any problem.

Jedit is v4.4.1 on Ubuntu 10.04 with current Sun Java.

Discussion

  • Bertalan Fodor
    Bertalan Fodor
    2011-11-21

    Thank you for the report.
    Could you please try the following workaround:
    - Open a(n old) .ly file
    - Press the convert-ly button (nothing happens)
    - Press Ctrl+S (ie. save the file)
    -- I expect here that convert-ly runs upon saving.

     
  • Bertalan Fodor
    Bertalan Fodor
    2011-11-21

    The previous idea might be totally wrong.
    Does your input file have a \version tag?

     
  • Nick Payne
    Nick Payne
    2011-11-21

    I tried that. When I press Ctrl+S, after pressing the convert-ly button, it runs lilypond against the file, rather than convert-ly. I slso notice that when I press the convert-ly button, some red text saying "1 error(s)" appears in the status bar at the bottom of the jedit window. And yes, the input file has a \version tag. I have uploaded the jedit activity.log file from trying what you suggested to http://www.users.on.net/~njpayne/music/. I tried to upload it here but the upload process kept hanging at 35%...

     
  • Bertalan Fodor
    Bertalan Fodor
    2011-11-21

    Hey, you found an interesting problem.
    Your input file cannot be parsed by the internal 2.14 parser, so it doesn't recognise the \version tag. I will fix this.
    Can you send me this test2.ly? To make sure that if it is 2.14 the parser works on it.

     
  • Nick Payne
    Nick Payne
    2011-11-21

    I've uploaded test2.ly to http://www.users.on.net/~njpayne/music/. The version of lilypond I have installed is 2.15.19.

     
  • Bertalan Fodor
    Bertalan Fodor
    2011-11-21

    Thanks, it seems that the rightHandFinger function doesn't parse correctly. I'm looking into it.