Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#1 Use native sets if available

open
nobody
None
5
2010-08-31
2010-08-31
Russell Ryba
No

trunk/src/mac/_bluetoothsockets.py uses "import sets" from Python 2.3.

The sets module has since become standard in later versions of python and displays a deprecation warning. Changed the code to use native set class if available, or continue to import sets if using an older version of python, maintaining backward compatibility.

Discussion

  • Russell Ryba
    Russell Ryba
    2010-08-31

    "svn diff" from rev 30

     
    Attachments