#211 Update to libindicate 0.7 API

closed-accepted
Lars Windolf
None
5
2012-09-01
2012-04-08
Chow Loong Jin
No

The attached patch updates Liferea's indicator support to use indicate-0.7 and indicate-gtk-0.7 which is found in Ubuntu 12.04.

Discussion

  • Lars Windolf
    Lars Windolf
    2012-04-12

    • assigned_to: nobody --> llando
     
  • Lars Windolf
    Lars Windolf
    2012-04-12

    Thanks for the patch. I'll merge the patch when Debian Wheezy upgrades to libindicate 0.7+ (currently at 0.6)

     
  • Lars Windolf
    Lars Windolf
    2012-04-12

    Thanks for the hint. I'll check this.

     
  • Lars Windolf
    Lars Windolf
    2012-04-12

    • status: open --> open-accepted
     
  • Lars Windolf
    Lars Windolf
    2012-04-12

    You were correct. The API change was introduced with 0.6 already. I changed configure.ac to support both 0.6 and 0.7:

    if test "x$enable_libindicate" = "xyes"; then
    dnl Try 0.7 first
    PKG_CHECK_MODULES([LIBINDICATE], indicate-0.7 indicate-gtk-0.7,enable_libindicate=yes,enable_libindicate=no)
    AC_SUBST(LIBINDICATE_CFLAGS)
    AC_SUBST(LIBINDICATE_LIBS)

    dnl But 0.6 will also do...
    if test "x$enable_libindicate" = "xno"; then
    PKG_CHECK_MODULES([LIBINDICATE], indicate-0.6 indicate-gtk-0.6,enable_libindicate=yes,enable_libindicate=no)
    AC_SUBST(LIBINDICATE_CFLAGS)
    AC_SUBST(LIBINDICATE_LIBS)
    fi
    else
    enable_libindicate=no
    fi

    Solution added to git master. To be released with 1.9.4. Thanks for the patch and the suggestion!

     
  • Chow Loong Jin
    Chow Loong Jin
    2012-04-13

    Great thanks!

     
  • Lars Windolf
    Lars Windolf
    2012-09-01

    Patch was released with 1.9.4

     
  • Lars Windolf
    Lars Windolf
    2012-09-01

    • status: open-accepted --> closed-accepted