#1120 Liferea does not connect to proxy on localhost

v1.10
closed-wont-fix
Lars Windolf
None
5
2013-10-16
2013-10-12
David Smith
No

Version: 1.10.2

Distro bug reports:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=726091

Very old bug reports suggests that this issue might be an old one.

Old Distro bug reports (possibly related?):
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=555199

Discussion

  • genodeftest
    genodeftest
    2013-10-13

    I tested it and it partially worked:
    Using Tor on localhost port 9050 (socks proxy only, all other preferences in gnome-control-center -> network -> proxy -> manually are empty)
    ::1 does not work
    localhost does work
    127.0.0.1 does work

    btw: I don't think this is a bug in Liferea but in libsoup – but I'm not sure about that.

     
  • Lars Windolf
    Lars Windolf
    2013-10-16

    • status: open --> closed-wont-fix
    • assigned_to: Lars Windolf
     
  • Lars Windolf
    Lars Windolf
    2013-10-16

    Hi David,

    thanks for reporting this. I also believe it is not a problem of Liferea. Whatever you type in the proxy preferences is just passed as a proxy string to libsoup. And in this case "locahost:8080" or "127.0.0.1:8080" or "::1:8080" is passed to libsoup. Liferea has no influence on the processing.

    To check for the exact proxy definition passed to libsoup you can run

    liferea --debug-update | grep "Initializing libsoup"

    and check the passed proxy string.

    Best Regards,
    Lars