Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#1089 Double click does not open External Browser

v1.10
closed-fixed
Lars Windolf
None
5
2014-08-16
2013-06-26
johndoe18
No

I am running liferea 1.10-RC1 and in settings, I have unchecked the "Open links in lifereas window" box in the settings. Never the less, liferea still opens links inside the liferea window instead of the external browser when I double click a feed item.

Discussion

  • stqn
    stqn
    2013-07-18

    Same here under Arch Linux / Xfce, with Firefox set as default browser, Open links in Liferea un-checked, double-clicking on a feed item does not open the page in Firefox anymore, no matter what the preferences are set to (Default browser, Firefox). It opens the page inside Liferea itself.
    With Liferea 1.10.0.

     
    • Debian Package
      Debian Package
      2013-10-03

      A fix is in bug http://sourceforge.net/p/liferea/bugs/1056/
      I quote here :

      If you change the second argument for itemview_launch_URL(gchar, gboolean) >from FALSE to TRUE in on_popup_launch_item_selected(void) in >ui/item_list_view.c, double-clicking on an item will launch in your >external browser if it is set in the preferences.

       
  • I concur the above. While 'Default browser' worked as it said with 1.8.15, now it doesn't work at all.

     
  • Teodor Petrov
    Teodor Petrov
    2013-07-19

    Same here, running Gentoo and Firefox. Liferea 1.9.x something worked as expected.

     
  • Lars Windolf
    Lars Windolf
    2013-07-22

    Reproduced. This is a regression that needs to be fixed.

     
  • Lars Windolf
    Lars Windolf
    2013-07-22

    • assigned_to: Lars Windolf
     
  • Lars Windolf
    Lars Windolf
    2013-12-19

    Fixed in git master. Please retest.

    Will be released with 1.10.4

     
  • Lars Windolf
    Lars Windolf
    2013-12-19

    • status: open --> open-fixed
     
  • stqn
    stqn
    2013-12-27

    Works for me with today’s git version (d4896c6). Thanks!
    (Tested with https://aur.archlinux.org/packages/liferea-git/ )

     
  • Lars Windolf
    Lars Windolf
    2014-01-13

    1.10.4 was released.

     
  • Lars Windolf
    Lars Windolf
    2014-01-13

    • status: open-fixed --> closed-fixed
     
  • johndoe18
    johndoe18
    2014-01-14

    Sorry, but the problem not fixed in 1.10.4.
    Perhaps the patch did not make it back from the 1.11 branch?

    Please reopen this ticket, it is not fixed in 1.10.

     
  • Lars Windolf
    Lars Windolf
    2014-01-14

    • status: closed-fixed --> open-fixed
     
  • Lars Windolf
    Lars Windolf
    2014-01-14

    You are right. The fix missed 1.10.4. Will be in 1.10.5 which will be released soon.

     
  • Lars Windolf
    Lars Windolf
    2014-01-15

    Fix released with 1.10.5

     
  • Lars Windolf
    Lars Windolf
    2014-01-15

     
  • Lars Windolf
    Lars Windolf
    2014-01-15

    • status: open-fixed --> closed-fixed