#1078 Build scripts not picking up recent libindicate versions

v1.8
closed-fixed
Lars Windolf
None
5
2013-10-18
2013-05-22
Leon Nardella
No

It seems the build is broken in that it won't pick up recent enough libdindicate versions, since that project seems to have moved to a date-based versioning scheme, a la Ubuntu's.

Discussion

  • Mr Mago
    Mr Mago
    2013-06-08

    I can confirm. By manually adjusting configure (replacing "-0.5" with "-0.7") it is possible to get the build with enabled libindicate running, however it stops with this error (on Debian wheezy):

    ui/libliui.a(libliui_a-ui_indicator.o): In function add_node_indicator': /home/myuser/local/src/liferea-1.8.14/src/ui/ui_indicator.c:186: undefined reference toindicate_indicator_set_property_icon'
    collect2: error: ld returned 1 exit status

    I guess this has to do with the changed usage of the newer libindicate and is not surprising. In any case the libindicate support based on -0.5 is obsolete (at least for all current Debuntus).

     
  • Lars Windolf
    Lars Windolf
    2013-10-16

    • status: open --> closed-fixed
    • assigned_to: Lars Windolf
     
  • Lars Windolf
    Lars Windolf
    2013-10-16

    Please retest with latest releases. They now support libindicate 0.7 and 0.7

     
  • Leon Nardella
    Leon Nardella
    2013-10-18

    Hello, Lars.
    This bug seems to be fixed on 1.10.2. Thanks!