Tree [a516a7] master /
History



File Date Author Commit
build 2008-10-31 strbafridrich strbafridrich [f778ef] some work on smooth win32 crosscompiling
m4 2008-11-23 strbafridrich strbafridrich [b8c4d6] check for wpd2raw during configure so that one ...
src 2011-10-15 Miklos Vajna Miklos Vajna [a516a7] Implement defineSectionStyle() binding
.cvsignore 2008-11-20 strbafridrich strbafridrich [c1e032] require swig >= 1.3.30, because lower versions ...
LICENSE 2008-10-29 strbafridrich strbafridrich [c720e6] Initial revision
Makefile.am 2010-11-17 Fridrich Štrba Fridrich Štrba [ec697d] Generate ChangeLog on the dist-time
NEWS 2010-11-17 Fridrich Štrba Fridrich Štrba [ec697d] Generate ChangeLog on the dist-time
README 2008-10-29 strbafridrich strbafridrich [c720e6] Initial revision
autogen.sh 2008-10-30 strbafridrich strbafridrich [f34061] using ac_prog_* macros to determine where is ja...
buildnumber.sh 2008-10-29 strbafridrich strbafridrich [c720e6] Initial revision
configure.in 2010-11-17 Fridrich Štrba Fridrich Štrba [3fd22e] try to generate all version-dependent stuff
createBuildNumber.pl 2008-10-29 strbafridrich strbafridrich [c720e6] Initial revision
libwpd-bindings-zip.in 2008-11-17 strbafridrich strbafridrich [57ebd6] a small fix + adding win32 packaging
libwpd-bindings.spec.in 2008-11-11 strbafridrich strbafridrich [ae6bd2] on 64-bit, mono is in /usr/lib and not in /usr/...

Read Me

INSTALLATION:

Installation on Unix/Linux should be simple. Simply execute the following 
sequence of commands:

./configure ; make ; su -c 'make install'

Note that this assumes that you have development versions of glib (>= 2.0.0),
libgsf (>= 1.6.0), and libwpd (0.6.1) installed. I also assume that
you have pkgconfig installed.

This will make + install a single executable: wpd2odt. You may use it
on the command line as follows:

USAGE:

wpd2odt <infile> <outfile>

Where <infile> is a WordPerfect(tm) 6 (or greater document) and
<outfile> is the name of the target odt document, which wpd2odt will
create.

TROUBLESHOOTING:

You may need to add libwpd's pc to your pkgconfig path, if
/usr/local/lib/pkgconfig is not present. Try setting this environment
variable on the commandline (using bash):

export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig/

LINKS:

glib is available at http://www.gtk.org
libgsf is available at ftp://ftp.gnome.org/pub/GNOME/sources/libgsf
libwpd is available at http://libwpd.sf.net