Making it work on win 7 - 64 bits

Help
p3g4s3
2012-08-21
2013-11-04
  • p3g4s3
    p3g4s3
    2012-08-21

    Hello everyone !!

    Is there anybody who made this work on Windows 7 - 64 bits ?
    I'm having some trouble here :/

    If someone can help me, feel free to add me on skype : p3g4s3
    Or mail/gtalk : p3g4s3@gmail.com
    I need some explaination x)

    Thanks
    Regards
    Mat

     
  • Arpit
    Arpit
    2013-11-04

    Hi... Were you able to get it working on Windows 7 64 bits... I too want to get it working but not able to.

    Steps done:
    1) Downloaded libusb-win32-bin-1.2.6.0.zip (https://sourceforge.net/projects/libusb-win32/files/libusb-win32-releases/1.2.6.0/)
    2) Copied the libusb0.dll (from bin/x86 folder of the zip) into the C:/windows/system32 folder & libusb0.sys into the C:/Windows/System32/driver folder
    3) Downloaded LibusbJava_dll_0.2.4.0.zip and copied the LibusbJava.dll into the C:/Windows/System32 folder

    After that when it didn't work, I now did following steps:
    1) Copied the libusb0.dll (from bin/x86 folder of the zip) into the C:/windows/sysWOW64 folder & libusb0.sys into the C:/Windows/SysWow64/driver folder
    2) Downloaded LibusbJava_dll_64bit_0.2.4.0.zip and copied the LibusbJava.dll into the C:/Windows/SysWOW64 folder

    Still it didn't work...

    When running the LOG BUS program I am getting the following exception:

    Exception in thread "main" java.lang.UnsatisfiedLinkError: C:\Windows\System32\LibusbJava.dll: Can't find dependent libraries
    at java.lang.ClassLoader$NativeLibrary.load(Native Method)
    at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1807)
    at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1732)
    at java.lang.Runtime.loadLibrary0(Runtime.java:823)
    at java.lang.System.loadLibrary(System.java:1028)
    at ch.ntb.usb.LibusbJava.<clinit>(LibusbJava.java:336)
    at com.rt.usb.main.LogBus.logBus(LogBus.java:19)
    at com.rt.usb.main.LogBus.main(LogBus.java:35)

    In case someone has got it working or can explain me what I have done wrong, please let me know (in case you have working dll/sys files please e-mail on robin.carry@gmail.com)

     
    Last edit: Arpit 2013-11-04