Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#1 Jukebox is only found on first command

closed
Mechalas
None
5
2005-01-10
2001-09-29
Anonymous
No

I have a problem. My Nomad is found the first time I
try to send a track to it and the upload is successful.
On subsequent tries though I get a "no NJB devices found
" message. This continues until I unplug the USB cable
and re-insert it. Then goto the beginning of the problem.

I am using Linux 2.4.9 & lubUSB with a UHCI interface.
Any help would be appreciated.

Dan

Discussion

  • Mechalas
    Mechalas
    2001-10-14

    Logged In: YES
    user_id=262681

    I am aware of this issue and am working on a fix.

     
  • Mechalas
    Mechalas
    2001-10-16

    Logged In: YES
    user_id=262681

    Make sure you have the latest sources for libusb. You will
    need to fetch them from the CVS archives here at
    SourceForge. Let me know if that does not resolve the
    issue.

     
  • Mechalas
    Mechalas
    2001-10-16

    • assigned_to: nobody --> mechalas
     
  • Mechalas
    Mechalas
    2002-02-24

    Logged In: YES
    user_id=262681

    This appears to be an issue with libusb under Linux, or with
    user-level USB in general under Linux, and not libnjb. I am
    aware of the problem, but have no sure-fire fix (other than
    to unplug/replug the device).

     
  • Linus Walleij
    Linus Walleij
    2005-01-10

    • status: open --> closed
     
  • Linus Walleij
    Linus Walleij
    2005-01-10

    Logged In: YES
    user_id=473872

    This has been fixed in the CVS and even in libnjb
    1.0/1.1/1.2 I believe.