On 08/08/2011 05:26 PM, Truman Ellis wrote:
I am trying to build the libmesh_tests, but I get a lot of errors as a result. Any help deciphering what is wrong on my machine would be appreciated.
-- 
Truman Ellis
$make
touch .depends
g++   -L/lib -lcppunit   /workspace/truman/libmesh/libmesh/lib/x86_64-unknown-linux-gnu_dbg/libmesh.so /workspace/truman/libmesh/libmesh/contrib/lib/x86_64-unknown-linux-gnu_dbg/liblaspack.so /workspace/truman/libmesh/libmesh/contrib/lib/x86_64-unknown-linux-gnu_dbg/libparmetis.so /workspace/truman/libmesh/libmesh/contrib/lib/x86_64-unknown-linux-gnu_dbg/libmetis.so /workspace/truman/libmesh/libmesh/contrib/lib/x86_64-unknown-linux-gnu_dbg/libsfcurves.so -L/org/centers/pecos/LIBRARIES/TBB/tbb-2.2.013-gcc-4.5-lucid/lib -ltbb -ltbbmalloc /workspace/truman/libmesh/libmesh/contrib/lib/x86_64-unknown-linux-gnu_dbg/libgzstream.so -lz /workspace/truman/libmesh/libmesh/contrib/tecplot/lib/x86_64-unknown-linux-gnu/tecio.a /workspace/truman/libmesh/libmesh/contrib/lib/x86_64-unknown-linux-gnu_dbg/libgmv.so -Wl,-rpath,/org/centers/pecos/LIBRARIES/VTK/vtk-5.4.2-gcc-4.5-lucid/lib/vtk-5.4 -L/org/centers/pecos/LIBRARIES/VTK/vtk-5.4.2-gcc-4.5-lucid/lib/vtk-5.4 -lvtkIO -lvtkCommon -lvtkFiltering /workspace/truman/libmesh/libmesh/contrib/lib/x86_64-unknown-linux-gnu_dbg/libtetgen.so /workspace/truman/libmesh/libmesh/contrib/lib/x86_64-unknown-linux-gnu_dbg/libtriangle.so /workspace/truman/libmesh/libmesh/contrib/lib/x86_64-unknown-linux-gnu_dbg/libexodusii.so /workspace/truman/libmesh/libmesh/contrib/lib/x86_64-unknown-linux-gnu_dbg/libnetcdf.so /workspace/truman/libmesh/libmesh/contrib/lib/x86_64-unknown-linux-gnu_dbg/libnemesis.so /workspace/truman/libmesh/libmesh/contrib/lib/x86_64-unknown-linux-gnu_dbg/libHilbert.so -L/org/centers/pecos/LIBRARIES/OPENMPI/openmpi-1.4.1-gcc-4.5-lucid/lib -L/org/centers/pecos/LIBRARIES/TRILINOS/trilinos-9.0.3-gcc-4.5-lucid-mkl-10.0.3.020-openmpi-1.4.1/lib -laztecoo -ltriutils -L/org/centers/pecos/LIBRARIES/MKL/mkl-10.0.3.020-gcc-4.5-lucid/lib/em64t -L/org/centers/pecos/LIBRARIES/GCC/gcc-4.5.1-lucid/lib/gcc/x86_64-unknown-linux-gnu/4.5.1 -L/org/centers/pecos/LIBRARIES/GCC/gcc-4.5.1-lucid/lib64 -L/org/centers/pecos/LIBRARIES/GCC/gcc-4.5.1-lucid/lib -lepetra -lteuchos -lmkl_solver_lp64_sequential -lmkl_intel_lp64 -lmkl_sequential -lmkl_core -lmpi_f77 -lmpi -lopen-rte -lopen-pal -ldl -lnsl -lutil -lgfortran -lm -lpthread -L/org/centers/pecos/LIBRARIES/OPENMPI/openmpi-1.4.1-gcc-4.5-lucid/lib -L/org/centers/pecos/LIBRARIES/TRILINOS/trilinos-9.0.3-gcc-4.5-lucid-mkl-10.0.3.020-openmpi-1.4.1/lib -lnoxepetra -lnox -lml -L/org/centers/pecos/LIBRARIES/MKL/mkl-10.0.3.020-gcc-4.5-lucid/lib/em64t -L/org/centers/pecos/LIBRARIES/GCC/gcc-4.5.1-lucid/lib/gcc/x86_64-unknown-linux-gnu/4.5.1 -L/org/centers/pecos/LIBRARIES/GCC/gcc-4.5.1-lucid/lib64 -L/org/centers/pecos/LIBRARIES/GCC/gcc-4.5.1-lucid/lib -lifpack -lamesos -lepetraext -laztecoo -ltriutils -lepetra -lteuchos -lmkl_solver_lp64_sequential -lmkl_intel_lp64 -lmkl_sequential -lmkl_core -lgfortran -lm -lmpi_f77 -lmpi -lopen-rte -lopen-pal -ldl -lnsl -lutil -lpthread -Wl,-rpath,/org/centers/pecos/LIBRARIES/PETSC3/petsc-3.1-p5/gcc-4.5-lucid-openmpi-1.4.1-cxx-opt/lib -L/org/centers/pecos/LIBRARIES/PETSC3/petsc-3.1-p5/gcc-4.5-lucid-openmpi-1.4.1-cxx-opt/lib -lpetsc -lX11 -Wl,-rpath,/org/centers/pecos/LIBRARIES/PETSC3/petsc-3.1-p5/gcc-4.5-lucid-openmpi-1.4.1-cxx-opt/lib -L/org/centers/pecos/LIBRARIES/PETSC3/petsc-3.1-p5/gcc-4.5-lucid-openmpi-1.4.1-cxx-opt/lib -lHYPRE -lsuperlu_dist_2.4 -lcmumps -ldmumps -lsmumps -lzmumps -lmumps_common -lpord -lparmetis -lmetis -lscalapack -lblacs -lsuperlu_4.0 -Wl,-rpath,/org/centers/pecos/LIBRARIES/MKL/mkl-10.0.3.020-gcc-4.5-lucid/lib/em64t -L/org/centers/pecos/LIBRARIES/MKL/mkl-10.0.3.020-gcc-4.5-lucid/lib/em64t -lmkl_solver_lp64_sequential -lmkl_intel_lp64 -lmkl_sequential -lmkl_core -Wl,-rpath,/org/centers/pecos/LIBRARIES/OPENMPI/openmpi-1.4.1-gcc-4.5-lucid/lib -L/org/centers/pecos/LIBRARIES/OPENMPI/openmpi-1.4.1-gcc-4.5-lucid/lib -Wl,-rpath,/org/centers/pecos/LIBRARIES/GCC/gcc-4.5.1-lucid/lib/gcc/x86_64-unknown-linux-gnu/4.5.1 -L/org/centers/pecos/LIBRARIES/GCC/gcc-4.5.1-lucid/lib/gcc/x86_64-unknown-linux-gnu/4.5.1 -Wl,-rpath,/org/centers/pecos/LIBRARIES/GCC/gcc-4.5.1-lucid/lib64 -L/org/centers/pecos/LIBRARIES/GCC/gcc-4.5.1-lucid/lib64 -Wl,-rpath,/org/centers/pecos/LIBRARIES/GCC/gcc-4.5.1-lucid/lib -L/org/centers/pecos/LIBRARIES/GCC/gcc-4.5.1-lucid/lib -ldl -lmpi -lopen-rte -lopen-pal -lnsl -lutil -lgcc_s -lpthread -lmpi_f90 -lmpi_f77 -lgfortran -lm -lm -lm -lm -lmpi_cxx -lstdc++ -ldl -lmpi -lopen-rte -lopen-pal -lnsl -lutil -lgcc_s -lpthread -ldl -Wl,-rpath,/workspace/truman/libmesh/libmesh/lib/x86_64-unknown-linux-gnu_dbg -Wl,-rpath,/workspace/truman/libmesh/libmesh/contrib/lib/x86_64-unknown-linux-gnu_dbg -Wl,-rpath,/org/centers/pecos/LIBRARIES/PETSC3/petsc-3.1-p5/gcc-4.5-lucid-openmpi-1.4.1-cxx-opt/lib -Wl,-rpath,/workspace/truman/libmesh/libmesh/lib/x86_64-unknown-linux-gnu_dbg -Wl,-rpath,/workspace/truman/libmesh/libmesh/contrib/lib/x86_64-unknown-linux-gnu_dbg -Wl,-rpath,/org/centers/pecos/LIBRARIES/PETSC3/petsc-3.1-p5/gcc-4.5-lucid-openmpi-1.4.1-cxx-opt/lib   ./quadrature/quadrature_test.o ./driver.o ./geom/node_test.o ./geom/point_test.o ./numerics/laspack_vector_test.o ./numerics/petsc_vector_test.o ./numerics/distributed_vector_test.o ./numerics/trilinos_epetra_vector_test.o ./parallel/parallel_test.o -o run_tests
mpirun -np 4 ./run_tests -pc_type bjacobi -sub_pc_type ilu -sub_pc_factor_levels 4 -sub_pc_factor_zeropivot 0 -ksp_right_pc -log_summary
[0]PETSC ERROR: ------------------------------------------------------------------------
[0]PETSC ERROR: Caught signal number 11 SEGV: Segmentation Violation, probably memory access out of range
[0]PETSC ERROR: Try option -start_in_debugger or -on_error_attach_debugger
[0]PETSC ERROR: or see http://www.mcs.anl.gov/petsc/petsc-as/documentation/troubleshooting.html#Signal[0]PETSC ERROR: [2]PETSC ERROR: ------------------------------------------------------------------------
[2]PETSC ERROR: Caught signal number 11 SEGV: Segmentation Violation, probably memory access out of range
[2]PETSC ERROR: Try option -start_in_debugger or -on_error_attach_debugger
[2]PETSC ERROR: or see http://www.mcs.anl.gov/petsc/petsc-as/documentation/troubleshooting.html#Signal[2]PETSC ERROR: or try http://valgrind.org on GNU/linux and Apple Mac OS X to find memory corruption errors
[2]PETSC ERROR: configure using --with-debugging=yes, recompile, link, and run
[2]PETSC ERROR: to get more information on the crash.
[3]PETSC ERROR: [1]PETSC ERROR: ------------------------------------------------------------------------
[1]PETSC ERROR: Caught signal number 11 SEGV: Segmentation Violation, probably memory access out of range
[1]PETSC ERROR: Try option -start_in_debugger or -on_error_attach_debugger
[1]PETSC ERROR: or see http://www.mcs.anl.gov/petsc/petsc-as/documentation/troubleshooting.html#Signal[1]PETSC ERROR: or try http://valgrind.org on GNU/linux and Apple Mac OS X to find memory corruption errors
[1]PETSC ERROR: configure using --with-debugging=yes, recompile, link, and run
[1]PETSC ERROR: to get more information on the crash.
or try http://valgrind.org on GNU/linux and Apple Mac OS X to find memory corruption errors
[0]PETSC ERROR: configure using --with-debugging=yes, recompile, link, and run
[0]PETSC ERROR: to get more information on the crash.
[1]PETSC ERROR: --------------------- Error Message ------------------------------------
[1]PETSC ERROR: Signal received!
[1]PETSC ERROR: ------------------------------------------------------------------------
[1]PETSC ERROR: Petsc Release Version 3.1.0, Patch 5, Mon Sep 27 11:51:54 CDT 2010
[1]PETSC ERROR: See docs/changes/index.html for recent updates.
[1]PETSC ERROR: See docs/faq.html for hints about trouble shooting.
[1]PETSC ERROR: See docs/index.html for manual pages.
[1]PETSC ERROR: ------------------------------------------------------------------------
[1]PETSC ERROR: ./run_tests on a gcc-4.5-l named bertrand by truman Mon Aug  8 17:23:13 2011
[1]PETSC ERROR: Libraries linked from /org/centers/pecos/LIBRARIES/PETSC3/petsc-3.1-p5/gcc-4.5-lucid-openmpi-1.4.1-cxx-opt/lib
[1]PETSC ERROR: Configure run at Fri Oct  8 09:41:10 2010
[1]PETSC ERROR: Configure options --with-debugging=false --COPTFLAGS=-O3 --CXXOPTFLAGS=-O3 --FOPTFLAGS=-O3 --with-clanguage=C++ --with-shared=1 --with-mpi-dir=/org/centers/pecos/LIBRARIES/OPENMPI/openmpi-1.4.1-gcc-4.5-lucid --with-mumps=true --download-mumps=ifneeded --with-parmetis=true --download-parmetis=ifneeded --with-superlu=true --download-superlu=ifneeded --with-superludir=true --download-superlu_dist=ifneeded --with-blacs=true --download-blacs=ifneeded --with-scalapack=true --download-scalapack=ifneeded --with-hypre=true --download-hypre=ifneeded --with-blas-lib="[/org/centers/pecos/LIBRARIES/MKL/mkl-10.0.3.020-gcc-4.5-lucid/lib/em64t/libmkl_intel_lp64.so,/org/centers/pecos/LIBRARIES/MKL/mkl-10.0.3.020-gcc-4.5-lucid/lib/em64t/libmkl_sequential.so,/org/centers/pecos/LIBRARIES/MKL/mkl-10.0.3.020-gcc-4.5-lucid/lib/em64t/libmkl_core.so]"--with-lapack-lib=/org/centers/pecos/LIBRARIES/MKL/mkl-10.0.3.020-gcc-4.5-lucid/lib/em64t/libmkl_solver_lp64_sequential.a
[1]PETSC ERROR: [2]PETSC ERROR: --------------------- Error Message ------------------------------------
[2]PETSC ERROR: Signal received!
[2]PETSC ERROR: ------------------------------------------------------------------------
[2]PETSC ERROR: Petsc Release Version 3.1.0, Patch 5, Mon Sep 27 11:51:54 CDT 2010
[2]PETSC ERROR: See docs/changes/index.html for recent updates.
[2]PETSC ERROR: See docs/faq.html for hints about trouble shooting.
[2]PETSC ERROR: See docs/index.html for manual pages.
[2]PETSC ERROR: ------------------------------------------------------------------------
[2]PETSC ERROR: ./run_tests on a gcc-4.5-l named bertrand by truman Mon Aug  8 17:23:13 2011
[2]PETSC ERROR: Libraries linked from /org/centers/pecos/LIBRARIES/PETSC3/petsc-3.1-p5/gcc-4.5-lucid-openmpi-1.4.1-cxx-opt/lib
[2]PETSC ERROR: Configure run at Fri Oct  8 09:41:10 2010
[2]PETSC ERROR: Configure options --with-debugging=false --COPTFLAGS=-O3 --CXXOPTFLAGS=-O3 --FOPTFLAGS=-O3 --with-clanguage=C++ --with-shared=1 --with-mpi-dir=/org/centers/pecos/LIBRARIES/OPENMPI/openmpi-1.4.1-gcc-4.5-lucid --with-mumps=true --download-mumps=ifneeded --with-parmetis=true --download-parmetis=ifneeded --with-superlu=true --download-superlu=ifneeded --with-superludir=true --download-superlu_dist=ifneeded --with-blacs=true --download-blacs=ifneeded --with-scalapack=true --download-scalapack=ifneeded --with-hypre=true --download-hypre=ifneeded --with-blas-lib="[/org/centers/pecos/LIBRARIES/MKL/mkl-10.0.3.020-gcc-4.5-lucid/lib/em64t/libmkl_intel_lp64.so,/org/centers/pecos/LIBRARIES/MKL/mkl-10.0.3.020-gcc-4.5-lucid/lib/em64t/libmkl_sequential.so,/org/centers/pecos/LIBRARIES/MKL/mkl-10.0.3.020-gcc-4.5-lucid/lib/em64t/libmkl_core.so]"--with-lapack-lib=/org/centers/pecos/LIBRARIES/MKL/mkl-10.0.3.020-gcc-4.5-lucid/lib/em64t/libmkl_solver_lp64_sequential.a
[2]PETSC ERROR: ------------------------------------------------------------------------
[2]PETSC ERROR: User provided function() line 0 in unknown directory unknown file
[0]PETSC ERROR: --------------------- Error Message ------------------------------------
[0]PETSC ERROR: Signal received!
[0]PETSC ERROR: ------------------------------------------------------------------------
[0]PETSC ERROR: Petsc Release Version 3.1.0, Patch 5, Mon Sep 27 11:51:54 CDT 2010
[0]PETSC ERROR: See docs/changes/index.html for recent updates.
[0]PETSC ERROR: See docs/faq.html for hints about trouble shooting.
[0]PETSC ERROR: See docs/index.html for manual pages.
[0]PETSC ERROR: ------------------------------------------------------------------------
[0]PETSC ERROR: ./run_tests on a gcc-4.5-l named bertrand by truman Mon Aug  8 17:23:13 2011
[0]PETSC ERROR: Libraries linked from /org/centers/pecos/LIBRARIES/PETSC3/petsc-3.1-p5/gcc-4.5-lucid-openmpi-1.4.1-cxx-opt/lib
[0]PETSC ERROR: Configure run at Fri Oct  8 09:41:10 2010
[0]PETSC ERROR: Configure options --with-debugging=false --COPTFLAGS=-O3 --CXXOPTFLAGS=-O3 --FOPTFLAGS=-O3 --with-clanguage=C++ --with-shared=1 --with-mpi-dir=/org/centers/pecos/LIBRARIES/OPENMPI/openmpi-1.4.1-gcc-4.5-lucid --with-mumps=true --download-mumps=ifneeded --with-parmetis=true --download-parmetis=ifneeded --with-superlu=true --download-superlu=ifneeded --with-superludir=true --download-superlu_dist=ifneeded --with-blacs=true --download-blacs=ifneeded --with-scalapack=true --download-scalapack=ifneeded --with-hypre=true --download-hypre=ifneeded --with-blas-lib="[/org/centers/pecos/LIBRARIES/MKL/mkl-10.0.3.020-gcc-4.5-lucid/lib/em64t/libmkl_intel_lp64.so,/org/centers/pecos/LIBRARIES/MKL/mkl-10.0.3.020-gcc-4.5-lucid/lib/em64t/libmkl_sequential.so,/org/centers/pecos/LIBRARIES/MKL/mkl-10.0.3.020-gcc-4.5-lucid/lib/em64t/libmkl_core.so]"--with-lapack-lib=/org/centers/pecos/LIBRARIES/MKL/mkl-10.0.3.020-gcc-4.5-lucid/lib/em64t/libmkl_solver_lp64_sequential.a
[0]PETSC ERROR: ------------------------------------------------------------------------
[0]PETSC ERROR: User provided function() line 0 in unknown directory unknown file
------------------------------------------------------------------------
[1]PETSC ERROR: User provided function() line 0 in unknown directory unknown file
------------------------------------------------------------------------
[3]PETSC ERROR: Caught signal number 11 SEGV: Segmentation Violation, probably memory access out of range
[3]PETSC ERROR: Try option -start_in_debugger or -on_error_attach_debugger
[3]PETSC ERROR: or see http://www.mcs.anl.gov/petsc/petsc-as/documentation/troubleshooting.html#Signal[3]PETSC ERROR: or try http://valgrind.org on GNU/linux and Apple Mac OS X to find memory corruption errors
[3]PETSC ERROR: configure using --with-debugging=yes, recompile, link, and run
[3]PETSC ERROR: to get more information on the crash.
[3]PETSC ERROR: --------------------- Error Message ------------------------------------
[3]PETSC ERROR: Signal received!
[3]PETSC ERROR: ------------------------------------------------------------------------
[3]PETSC ERROR: Petsc Release Version 3.1.0, Patch 5, Mon Sep 27 11:51:54 CDT 2010
[3]PETSC ERROR: See docs/changes/index.html for recent updates.
[3]PETSC ERROR: See docs/faq.html for hints about trouble shooting.
[3]PETSC ERROR: See docs/index.html for manual pages.
[3]PETSC ERROR: ------------------------------------------------------------------------
[3]PETSC ERROR: ./run_tests on a gcc-4.5-l named bertrand by truman Mon Aug  8 17:23:13 2011
[3]PETSC ERROR: Libraries linked from /org/centers/pecos/LIBRARIES/PETSC3/petsc-3.1-p5/gcc-4.5-lucid-openmpi-1.4.1-cxx-opt/lib
[3]PETSC ERROR: Configure run at Fri Oct  8 09:41:10 2010
[3]PETSC ERROR: Configure options --with-debugging=false --COPTFLAGS=-O3 --CXXOPTFLAGS=-O3 --FOPTFLAGS=-O3 --with-clanguage=C++ --with-shared=1 --with-mpi-dir=/org/centers/pecos/LIBRARIES/OPENMPI/openmpi-1.4.1-gcc-4.5-lucid --with-mumps=true --download-mumps=ifneeded --with-parmetis=true --download-parmetis=ifneeded --with-superlu=true --download-superlu=ifneeded --with-superludir=true --download-superlu_dist=ifneeded --with-blacs=true --download-blacs=ifneeded --with-scalapack=true --download-scalapack=ifneeded --with-hypre=true --download-hypre=ifneeded --with-blas-lib="[/org/centers/pecos/LIBRARIES/MKL/mkl-10.0.3.020-gcc-4.5-lucid/lib/em64t/libmkl_intel_lp64.so,/org/centers/pecos/LIBRARIES/MKL/mkl-10.0.3.020-gcc-4.5-lucid/lib/em64t/libmkl_sequential.so,/org/centers/pecos/LIBRARIES/MKL/mkl-10.0.3.020-gcc-4.5-lucid/lib/em64t/libmkl_core.so]"--with-lapack-lib=/org/centers/pecos/LIBRARIES/MKL/mkl-10.0.3.020-gcc-4.5-lucid/lib/em64t/libmkl_solver_lp64_sequential.a
[3]PETSC ERROR: ------------------------------------------------------------------------
[3]PETSC ERROR: User provided function() line 0 in unknown directory unknown file
--------------------------------------------------------------------------
MPI_ABORT was invoked on rank 0 in communicator MPI COMMUNICATOR 3 DUP FROM 0
with errorcode 59.

NOTE: invoking MPI_ABORT causes Open MPI to kill all MPI processes.
You may or may not see output from other processes, depending on
exactly when Open MPI kills them.
--------------------------------------------------------------------------
[bertrand:28985] 3 more processes have sent help message help-mpi-api.txt / mpi-abort
[bertrand:28985] Set MCA parameter "orte_base_help_aggregate" to 0 to see all help / error messages
mpirun: killing job...

--------------------------------------------------------------------------
mpirun noticed that process rank 0 with PID 28986 on node bertrand exited on signal 0 (Unknown signal 0).
--------------------------------------------------------------------------
mpirun: clean termination accomplished

4 total processes killed (some possibly by mpirun during cleanup)
make: *** [all] Error 1

------------------------------------------------------------------------------ Get a FREE DOWNLOAD! and learn more about uberSVN rich system, user administration capabilities and model configuration. Take the hassle out of deploying and managing Subversion and the tools developers use with it. http://p.sf.net/sfu/wandisco-d2d-2
_______________________________________________ Libmesh-devel mailing list Libmesh-devel@lists.sourceforge.net https://lists.sourceforge.net/lists/listinfo/libmesh-devel
Please ignore this, it is several weeks old and just got sent for some reason. I figured out the problem.

-- 
Truman Ellis