Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#43 Cann't build libdv rpm under FC4 with fresh install

open
nobody
None
5
2005-12-10
2005-12-10
Anonymous
No

I looked through the open bug reports on libdv's
SourceForge and did not see any mention of the
following problem I encountered when attempting to
build the libdv rpm.

After downloading from CVS the current libdv source I ran
$ ./configure
$ make
$ make distribution
with no problem.
Attempting to build rpm with
# make rpm
returned the following error:
.
.
.
rpmbuild -ta libdv-0.104.tar.gz
error: Legacy syntax is unsupported: copyright
error: line 7: Unknown tag: CopyRight: GPL
make: *** [rpm] Error 1
#
Changing the libdv.spec file's
CopyRight: GPL
line to
License: GPL
corrected the problem.
I run Fedora Core 4 on a AMD64 machine which currently
has rpmbuild Version 4.4.1. I do not know when (what
version) of rpmbuild stopped supporting legacy syntax
(i.e. CopyRight flag) and began requiring the License
flag but this is probably going to become an issue as
users/developers begin using newer versions of rpm.

Dave
eager1@holidayceramicsinc.com

Discussion