#894 LedgerSMB::Database has incorrect handling for failed logins

1.3
closed-works-for-me
nobody
None
5
2014-01-15
2013-11-03
Chris Travers
No

When a login fails on setup.pl, we get a nasty error as follows (sample from 1.4, so line numbers may be different). Tracking down the error shows that this happens because the dbh did not get created due to a login issue:

Can't call method "selectrow_array" on an undefined value at LedgerSMB/Database.pm line 393.

This does appear to affect 1.3 and 1.4 equally. We should be sending 401's out in these cases.

Discussion

  • Chris Travers
    Chris Travers
    2014-01-15

    • status: open --> closed-works-for-me
     
    • see also
      trunk
      [r6460]

      /trunk/LedgerSMB/Auth/DB.pm

      after logout on normal application (login.pl) and coming to setup.pl,
      auth seems to be logout:logout

      2014/1/15 Chris Travers einhverfr@users.sf.net:

      status: open --> closed-works-for-me


      [bugs:#894] LedgerSMB::Database has incorrect handling for failed logins

      Status: closed-works-for-me
      Created: Sun Nov 03, 2013 06:16 AM UTC by Chris Travers
      Last Updated: Sun Nov 03, 2013 06:16 AM UTC
      Owner: nobody

      When a login fails on setup.pl, we get a nasty error as follows (sample from
      1.4, so line numbers may be different). Tracking down the error shows that
      this happens because the dbh did not get created due to a login issue:

      Can't call method "selectrow_array" on an undefined value at
      LedgerSMB/Database.pm line 393.

      This does appear to affect 1.3 and 1.4 equally. We should be sending 401's
      out in these cases.


      Sent from sourceforge.net because you indicated interest in
      https://sourceforge.net/p/ledger-smb/bugs/894/

      To unsubscribe from further messages, please visit
      https://sourceforge.net/auth/subscriptions/

       
  • Chris Travers
    Chris Travers
    2014-01-15

    I couldn't reproduce this anymore. It may have been 1.4 only before the setup.pm was rewritten and db connections centralized. closing "works for me"