Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#2 sli_drv cannot be configured/compiled

critical
closed-fixed
nobody
server (16)
5
2001-09-27
2001-09-22
No

# configure --enable-drivers=sli_drv
...
checking for which drivers to compile... sli_drv
configure: error: Unknown driver sli_drv

This is, obviously, a bad thing. Appears on Solaris and
Linux at least.

Discussion

  • Logged In: YES
    user_id=53970

    okay, I found the message about this in the mailing list
    archive:

    From: Robin Adams <robin@adams-online.de>
    Rene Wagner wrote:
    > I have just written the driver for my LCD device, which
    I've got from
    > kernelconcepts.de.
    > The problem is adding the driver to the ones to be
    actually compiled.

    You need to tell automake about your new driver. You
    probably already
    have added your driver to /server/drivers/lcd.c , right?
    Then have a look at these files:
    acconfig.h
    acinclude.m4
    server/drivers/Makefile.am

    You need to add your driver to these files. If you can't
    figure out how to do it send it to me and I'll do a patch
    for you.

    ---
    Maibe we should add a file describing how to do this in
    the docs directory.

     
  • Logged In: YES
    user_id=53970

    okay, I found the message about this in the mailing list
    archive:

    From: Robin Adams <robin@adams-online.de>
    Rene Wagner wrote:
    > I have just written the driver for my LCD device, which
    I've got from
    > kernelconcepts.de.
    > The problem is adding the driver to the ones to be
    actually compiled.

    You need to tell automake about your new driver. You
    probably already
    have added your driver to /server/drivers/lcd.c , right?
    Then have a look at these files:
    acconfig.h
    acinclude.m4
    server/drivers/Makefile.am

    You need to add your driver to these files. If you can't
    figure out how to do it send it to me and I'll do a patch
    for you.

    ---
    Maibe we should add a file describing how to do this in
    the docs directory.

     
  • Robin Adams
    Robin Adams
    2001-09-22

    Logged In: YES
    user_id=177132

    The driver is called 'sli' !

    ./configure --enable-drivers=sli

    works for me.
    Hmmm... the source file ist called wirz-sli, elsewhere
    it is called sli_drv and elsewhere sli. We probably
    should agree on one name :-).
    It also doesn't get compiled when 'all drivers' is
    selected, which is a bug.

     
    • status: open --> closed-fixed
     
  • Logged In: YES
    user_id=839

    Yup, that solves it. I'll close this bug and open a new one
    (the driver works, it just has various names in different
    places :)