Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Mathy 2.0

jiquera
2008-03-01
2013-05-29
  • jiquera
    jiquera
    2008-03-01

    Ey guys
    next few weeks i have time to code the new mathy plugin, i dont have much time so it has to be done asap :P can someone tell me how i should set up my IDE? I dont want to copy one of the official plugins and then start editing, i want it from scratch. Im using MVS 2005, i have QT installed but i dont have much experience with make files, and those are confusing me...

    so any help would be appreciated :D

    thx in advance

    grtz

    jiq

     
    • Josh
      Josh
      2008-06-16

      Hi Jiquera,

      The documentation is available now.. including an example plugin project.  http://www.launchy.net/api2.0/

      Josh

       
    • jiquera
      jiquera
      2008-12-12

      Ey Josh,
      I'm thinking of writing Mathy for 2.1 (if there is demand for it that is), I started looking at the calcy source in the repository. In the source i don't understand the calculator class, it uses some grammar which looks very interesting, but where does it come from and how does it work?

      cheers

      jiq

       
    • Ryan Smith
      Ryan Smith
      2009-02-08

      Yes, please please PLEASE Mathy for 2.1x or 2.1 if 2.1x is not possible.

      I have been using 1.25 all this time simply because higher versions didn't run Mathy.  Nice to see I can at least go 2.0 now.

      Mathy is awesome!  Wish I was able to help, but I'm not a programmer.

      Thank you!

       
    • Ryan Smith
      Ryan Smith
      2009-02-08

      Woops...I'm confused.  I'm not sure if a Mathy that supports Launcy 2.0 is available or not.

      Is Mathy 1.7 the most recent version?

      Does 1.7 support Launchy 2.0?

      Or do I still need to use Launchy 1.25 to use Mathy?

      Thanks for any clarification!

       
    • Krewetka
      Krewetka
      2009-05-03

      Looks like there is no Mathy for Launchy 2.1. Am I right?

       
  • Amadawn
    Amadawn
    2010-06-09

    You guys should check the "Mathy Resurrected" plugin which has been created by "elgrunon" for Launchy 2.5.

    It has a ton of cool features, including support for complex numbers, as well as hexadecimal, binary and octal numbers.

    You can see the thread in this very same forum:

    https://sourceforge.net/projects/launchy/forums/forum/766269/topic/3362808

    Or you can go to the sourceforge project page to download it:

    http://sourceforge.net/projects/mathyresurected/

    I've been using it for the last few days and it works really well :-)

    Cheers,

    Amadawn