Launchy crashes after startup

Help
Adam
2012-08-23
2013-10-29
  • Adam
    Adam
    2012-08-23

    Hi,

    I've been running both the stable and the beta version of Launchy for some time now and everything was working perfectly fine. However, since like two weeks Launchy crashes immediately or a few minutes after I launch the app, with a window pop up saying "Sorry, launchy seems to have crashed", thats all. It happens on both the stable and the beta versions, although not if I install the portable version. This is a different problem, however, because althought the app doesn't crash anymore, it also fails to work properly, meaning it won't search what I'm looking for: nearly everything I search for provides me with a calc icon and a "0". which as I understand stands for "not found". Even if it find something it is usually something radically different from what I was looking for.

    Can someone provide me with assistance with this? Maybe there is a simple solution, however if there isn't I will gladly post the link to the launchy dump file (?). For the moment I don't have access to the server.

    Im running Windows 7 64 bit.

    Thank you very much for your help.

     

  • Anonymous
    2012-09-24

    I am having the same problem. I am running XP & don't even a msg. It just crashes and the tray icon vanishes.
    I tried uninstalling & reinstalling the 2.6 beta 2 but no joy.
    Anybody any idea ?

     
  • Zos474
    Zos474
    2012-11-23

    Exactly the same problem with me - was working fine until a few weeks ago.  But at least it is reproducable with me: whenever I delete what is currently showing in the launchy text box (e.g. by clicking backspace or delete) then it crashes.  I disabled the plugins to see if that was the issue & no difference.  Any suggestions really appreciated because this is very irritating.

     
  • larsen255
    larsen255
    2013-10-28

    Close Launchy and try to delete the file "%appdata%\Launchy\history.db". Solved another problem for me. Perhaps, deleting launchy.db helps, too.

     
  • Thanks! I think you just solved my launchy problem. Deleting history.db seems to have fixed it for me.