Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Launchy jumps to "Run" when press tab

Help
Rense
2013-08-27
2013-09-04
  • Rense
    Rense
    2013-08-27

    As the title says.... I want to pass some input to a program by using "tab" in Launchy, but in most cases, Launchy changes the found program to "Run" at the moment I press tab, with the exception of the Weby keywords. Does this behavior sound familiar to anybody, and even better, any solutions?

     
  • Roslin Hohum
    Roslin Hohum
    2013-09-04

    I'm having the same problem on Windows 64-bit.

    HAH! I WAS having that problem! The command looks as if it changes to run but it works as it should for me.

    In my search for a solution I came across this forum post about "how to run .bat file in Windows 7" at another site. Thanks to Common Tater at sevenforums!

    I found that explanation a little unclear so I'll write my version here.

    I wanted to set up launchy to append text to a text file. My batch files are one line: echo %*>>C:\todo\todo.txt

    1. Create the batch file in a location outside of the programs folders: the desktop, documents, etc. I'll use "MyDocs" hereafter.
    2. Copy the batch file and paste a shortcut in the same MyDocs folder.
    3. Right-click on the shortcut and select properties.
    4. Change the target to C:\Windows\System32\cmd.exe
    5. Change the "start in" location to the launch utilities folder. I used the default installation location: C:\Program Files (x86)\Launchy\Utilities
    6. Click the Advanced button
    7. Check the box "Run as Administrator"
    8. Okay your way out of the properties dialog.
    9. Copy the batch file and the shortcut to the Launchy Utilities folder.
    10. Open the Launchy options, click the catalog tab.
    11. Check "include executables"
    12. Add .bat and .lnk to the file types.
    13. Rescan the Launchy catalog.

    You should be good to go.

     
    Last edit: Roslin Hohum 2013-09-05