Stephen,

I've got an old kxstitch working here and made some kxs files, then tried to open them with kxstitch built from trunk and got an error opening them.  the console says the file format is not compatible.  I added some debug statements and it turns out my fileFormatVersion in document.cpp is 6, but there's no support for file format version 6 anymore, is this on purpose?  If not I'd like to add support for loading that format by reading how that format was read in the old code.

thanks,
Jeremy